Bug 178717 - mv fails (regression)
Summary: mv fails (regression)
Status: CLOSED DUPLICATE of bug 174253
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-23 18:52 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 09:23:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2006-01-23 18:52:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Epiphany/1.9.4

Description of problem:
Probably an selinux bug, but:

$ mv oldname/ newname/

Fails on FC5T2.

Removing the trailing slash works.

Regression.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Need Real Name 2006-01-23 19:13:30 UTC
No audit messages at all.

Comment 2 Tim Waugh 2006-01-23 22:59:06 UTC
Please be a bit more specific -- starting from an empty current directory, what
do you do?

Comment 3 Need Real Name 2006-01-24 07:04:52 UTC
It's the same from any directory.

The directory "b" does not exist, it is the new name for "a".

$ mkdir a
$ mv a/ b/

It fails on FC5T2. Works on FC4.

Comment 4 Tim Waugh 2006-01-24 09:23:13 UTC
> $ mkdir a

This is what I needed -- that 'a' is a directory and that 'b' doesn't exist yet.
 Thanks; this has already been reported.


*** This bug has been marked as a duplicate of 174253 ***


Note You need to log in before you can comment on or make changes to this bug.