Bug 178726 - org.eclipse.compare compatibility with eclipse-bugzilla
org.eclipse.compare compatibility with eclipse-bugzilla
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Igor Foox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 15:07 EST by Jeff Pound
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 15:24:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
org.eclipse.compare -- eclipse 3.2 M4 (19.34 KB, text/plain)
2006-01-23 15:07 EST, Jeff Pound
no flags Details

  None (edit)
Description Jeff Pound 2006-01-23 15:07:35 EST
Description of problem:
The org.eclipse.compare plug-in has changed quite a bit in eclipse 3.2 and our
patch for Patch API won't apply cleanly anymore. Attached is a new version of
our patch to make non-internal patch applying API.

Once I've finished a more robust implementation that supports files and
workspace resources as well as memory buffers I'll post it upstream.


Version-Release number of selected component (if applicable):
eclipse-3.2 M4
Comment 1 Jeff Pound 2006-01-23 15:07:36 EST
Created attachment 123589 [details]
org.eclipse.compare -- eclipse 3.2 M4
Comment 2 Ben Konrath 2006-09-20 18:19:30 EDT
Igor, what's the status of this?
Comment 3 Igor Foox 2006-09-21 11:14:18 EDT
We carry this patch in the bugzilla plugin. I'm not sure if we cary the 3.2
modifcations that Jeff posted here or not, and even if we do I'm not sure if
they're compatible with 3.2 final. In any case I discussed with Andrew earlier
that we should just drop the apply patch functionality from bugzilla for now and
stop carrying a patched org.eclipse.compare, since this complicates things
significantly when updating the update site on sourceware.org, and is a general
PITA. It would be useful to get upstream to take these patches or something
similar, but I don't know how easy that would be to do.
Comment 4 Ben Konrath 2006-09-21 11:33:31 EDT
Can I close this bug then?
Comment 5 Igor Foox 2006-09-21 12:41:52 EDT
Well we should take the functionality out of bugzilla first, and stop carrying a
modified org.eclipse.compare in our update site first. I'll try to take a look
at that this weekend.
Comment 6 Ben Konrath 2006-09-21 13:01:37 EDT
Sounds good. Whenever you have time is good, there's no real rush.
Comment 7 Ben Konrath 2007-02-06 14:08:28 EST
Igor, can we close this bug?
Comment 8 Igor Foox 2007-02-06 15:24:14 EST
Yup, since we're dropping bugzilla. Closing.

Note You need to log in before you can comment on or make changes to this bug.