Bug 178754 - Current azureus update mechanism doesn't work
Current azureus update mechanism doesn't work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 19:43 EST by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 12:31:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2006-01-23 19:43:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
azureus updates itself from the mother ship by rewriting Azureus2.jar.

We should modify the startup script to copy Azureus2.jar into ~/.Azureus/bin before running (if it doesn't exist already), and then tell azureus that's where it is installed.

The parts of the jar file that haven't changed will still run natively compiled code, and new parts will be interpreted (for now).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to run the updater to install and update.
2.
3.
  

Additional info:
Comment 1 Ignacio Vazquez-Abrams 2006-01-23 19:45:26 EST
A better option might be to remove the updater plugin from the package entirely
and allow rpm to do its job.
Comment 2 Anthony Green 2006-01-23 19:59:34 EST
(In reply to comment #1)
> A better option might be to remove the updater plugin from the package entirely
> and allow rpm to do its job.

...and create lots of work for me. :-)

But I think you're probably right.  It turns out that the updates don't happen
all that often.
Comment 3 Anthony Green 2006-02-09 02:37:16 EST
I'm back to looking at this again.

My current thinking is to completely disable the plugin installer/uninstaller,
as well as the ability to check for updates, and to bundle azureus with a small
number of useful plugins (that come with source). 
Comment 4 Anthony Green 2006-02-10 12:31:25 EST
I've disabled all updates.  I've also figured out how to package plugins with
azureus.  azureus-2_4_0_0-0_20060209cvs_fc5 will have all updates disabled,
plugin install/uninstall disabled, restart disabled, and comes bundled with two
plugins (azplugins and bdcc).  I plan on adding a couple more popular plugins. 
The azureus site ranks them by download count, which is convenient.  I'm closing
this issue.
Comment 5 Filip Tsachev 2006-03-14 11:44:35 EST
what about country (flag) plugin why not include it also?
Comment 6 Anthony Green 2006-03-15 08:30:13 EST
(In reply to comment #5)
> what about country (flag) plugin why not include it also?

I'll see about including that in my next spin.  If you don't see it in a week or
two, please file a new enhancement request for it.

Thanks,

AG

Comment 7 Ignacio Vazquez-Abrams 2006-03-15 09:08:20 EST
(In reply to comment #6)
> (In reply to comment #5)
> > what about country (flag) plugin why not include it also?
> 
> I'll see about including that in my next spin.  If you don't see it in a week or
> two, please file a new enhancement request for it.

Please read this before you do so:

http://www.fedoraproject.org/wiki/Languages#Flags

Note You need to log in before you can comment on or make changes to this bug.