Bug 178759 - system-config-kickstart fails to start.
system-config-kickstart fails to start.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 22:31 EST by Richard Hally
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 15:34:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hally 2006-01-23 22:31:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
when I try to start s-c-ks it fails as follows:

[root@localhost ~]# /usr/sbin/system-config-kickstart
/usr/share/system-config-kickstart/kickstartGui.py:76: GtkWarning: Theme directory 16x16/status16x16/stock/chart of theme gnome has no size field

  xml = gtk.glade.XML ("/usr/share/system-config-kickstart/system-config-kickstart.glade", domain=domain)
I/O warning : failed to load external entity "/usr/share/comps/i386/comps.xml"
Could not start because there is no /usr/share/comps/i386/comps.xml file.
Please make sure the comps package is installed.

[root@localhost ~]# rpm -q system-config-kickstart
system-config-kickstart-2.6.3-1

Please note that there is no copms *package* in devel and if I copy the comps.xml files from /var/cache/yum/development to the location above s-c-ks fails to start with another error.
 

Version-Release number of selected component (if applicable):
system-config-kickstart-2.6.3-1

How reproducible:
Always

Steps to Reproduce:
1.[root@localhost ~]# /usr/sbin/system-config-kickstart


Actual Results:  [root@localhost ~]# /usr/sbin/system-config-kickstart
/usr/share/system-config-kickstart/kickstartGui.py:76: GtkWarning: Theme directory 16x16/status16x16/stock/chart of theme gnome has no size field

  xml = gtk.glade.XML ("/usr/share/system-config-kickstart/system-config-kickstart.glade", domain=domain)
I/O warning : failed to load external entity "/usr/share/comps/i386/comps.xml"
Could not start because there is no /usr/share/comps/i386/comps.xml file.
Please make sure the comps package is installed.


Expected Results:  don't know, this is the first time I have tried this.

Additional info:
Comment 1 Chris Lumens 2006-01-31 10:29:38 EST
This has become a little more complicated as I'm moving the pirut interface (as
seen in anaconda) in as the package selection screen and that requires getting
some patches upstreamed into yum.  Everything but package deselection works at
the moment, which essentially puts it on par with the older s-c-kickstart but
I'm not going to rebuild until that works too.  Please stand by.
Comment 2 Chris Lumens 2006-02-03 15:34:06 EST
Actually, package-level manipulation can wait.  This one at least allows the
same group selection as the older version, but using our new pirut UI.

Note You need to log in before you can comment on or make changes to this bug.