Red Hat Bugzilla – Bug 178760
pwlib fails to keep version info
Last modified: 2007-11-30 17:11:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Description of problem:
I tried installing the new ekiga along with gnomemeeting, but the pwlib package causes problems. Trying to re-install gnomemeeting doesn't work either.
$ sudo rpm -ivh pwlib-1.8.7-1.FC4.i386.rpm
Preparing... ########################################### [100%]
package pwlib-1.9.2-1 (which is newer than pwlib-1.8.7-1.FC4) is already installed
file /usr/lib/libpt_linux_x86_r.so.1 from install of pwlib-1.8.7-1.FC4 conflicts with file from package pwlib-1.9.2-1
file /usr/lib/pwlib/devices/sound/alsa_pwplugin.so from install of pwlib-1.8.7-1.FC4 conflicts with file from package pwlib-1.9.2-1
file /usr/lib/pwlib/devices/videoinput/avc_pwplugin.so from install of pwlib-1.8.7-1.FC4 conflicts with file from package pwlib-1.9.2-1
file /usr/lib/pwlib/devices/videoinput/v4l_pwplugin.so from install of pwlib-1.8.7-1.FC4 conflicts with file from package pwlib-1.9.2-1
/usr/lib/libpt_linux_x86_r.so.1.8.7 is versioned, but alsa_pwplugin.so, avc_pwplugin.so, and v4l_pwplugin.so are not.
Is this a problem with gnomemeeting claiming supid dependencies? Or with pwlib failing to distinguish versions?
Version-Release number of selected component (if applicable):
Steps to Reproduce:
1. rpm -ivh pwlib-1.8.7-1.FC4.i386.rpm
Its not generally supported to install multiple versions of the same package.
Gnomemeeting might work if you rebuild it against the newer pwlib though.
If you want to use ekiga on fc4 i recommend that you first remove pwlib,
openh323 and gnomemeeting packages from your system.
Sure enough, I could manually install both gnomemeeting and ekiga by first
removing packages and then taking packages apart and installing components or
forcing installs.... but that's not the point.
> Its not generally supported to install multiple versions of the same package.
But it would not have been a problems if pwlib kept proper version information,
> Gnomemeeting might work if you rebuild it against the newer pwlib though.
The gnomemeeting package might install if fedora built it against the newer
"Automated" tools that require manual intervention are either "broken" or they
are NOT "automated". "not gnerally supported" suggests "sometimes supported,
but you never know" - which is why administration becomes a nightmare.
Eliminating version information suggests "version does not matter". Allowing
some package to specify a version suggests "version matters". Ok, which is it:
version matters? or does not matter?
The point would be to find a solution that works - rebuild gnomemeeting, version
pwlib, fix dependency specs, or _something_. "Not my problem" is NOT a solution.
I'm not sure what you are so worked up about. Its all very simple:
pwlib 1.7.x and pwlib 1.9.x are not compatible and cannot be installed at the
This means you cannot have gnomemeeting and ekiga on the same system. Someone
could fix this by doing lots of development work to make pwlib versioned, but I
doubt there is anyone who wants to spend time on the old version. If you dislike
the pwlib backwards compat strategy, complaint to its developers.
However, neighter ekiga nor pwlib 1.9 are in fc4, so this is not a problem for
fc4. In FC5 we will not ship gnomemeeting, and ekiga will conflict with it so
gnomemeeting will be auto-removed when you install ekiga.