Bug 178783 - authconfig seg faults when krb5.conf is missing admin_server option
authconfig seg faults when krb5.conf is missing admin_server option
Status: CLOSED DUPLICATE of bug 178784
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: authconfig (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 07:24 EST by ritz
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 08:06:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core file from the crash (324.00 KB, application/octet-stream)
2006-01-24 07:24 EST, ritz
no flags Details

  None (edit)
Description ritz 2006-01-24 07:24:36 EST
Description of problem:
authconfig crahes on customer system. Problem was traced to bad configuration file.


Version-Release number of selected component (if applicable):
authconfig-4.3.7-3

How reproducible:
always

Steps to Reproduce:
usr/sbin/authconfig --nostart --kickstart --enablenis --nisdomain ctc
--nisserver linux75,linux76,linux77 --enableshadow --enablemd5 --enablekrb5
--krb5realm AD.CTCGSC.ORG --krb5kdc unix-ad.ctc.com:88

  
Actual results:
segmentation fault

Expected results:
graceful degradation

Additional info:
traced to missing "admin_server" in krb5.conf file
works fine without "--kickstart" option
Comment 1 ritz 2006-01-24 07:24:37 EST
Created attachment 123610 [details]
Core file from the crash
Comment 2 Tomas Mraz 2006-01-24 08:06:35 EST

*** This bug has been marked as a duplicate of 178784 ***

Note You need to log in before you can comment on or make changes to this bug.