Bug 178784 - authconfig seg faults when krb5.conf is missing admin_server option
Summary: authconfig seg faults when krb5.conf is missing admin_server option
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: authconfig   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: EasyFix, Patch
: 178783 (view as bug list)
Depends On:
Blocks: 178252 187539
TreeView+ depends on / blocked
 
Reported: 2006-01-24 12:24 UTC by ritz
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2006-0226
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 20:48:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core file from the crash (324.00 KB, application/octet-stream)
2006-01-24 12:24 UTC, ritz
no flags Details
Patch file (696 bytes, patch)
2006-01-24 12:29 UTC, ritz
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0226 normal SHIPPED_LIVE authconfig bug fix update 2006-07-19 20:39:00 UTC

Description ritz 2006-01-24 12:24:50 UTC
Description of problem:
authconfig crahes on customer system. Problem was traced to bad configuration file.


Version-Release number of selected component (if applicable):
authconfig-4.3.7-3

How reproducible:
always

Steps to Reproduce:
usr/sbin/authconfig --nostart --kickstart --enablenis --nisdomain ctc
--nisserver linux75,linux76,linux77 --enableshadow --enablemd5 --enablekrb5
--krb5realm AD.CTCGSC.ORG --krb5kdc unix-ad.ctc.com:88

  
Actual results:
segmentation fault

Expected results:
graceful degradation

Additional info:
traced to missing "admin_server" in krb5.conf file
works fine without "--kickstart" option

Comment 3 Tomas Mraz 2006-01-24 13:06:42 UTC
*** Bug 178783 has been marked as a duplicate of this bug. ***

Comment 8 Red Hat Bugzilla 2006-03-29 20:48:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0226.html



Note You need to log in before you can comment on or make changes to this bug.