Bug 178787 - Search in binary files may report false negatives
Search in binary files may report false negatives
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: less (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 08:22 EST by Miloslav Trmač
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 06:07:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2006-01-24 08:22:09 EST
Description of problem:
(less /usr/share/emacs/21.4/lisp/man.elc), search for "dumb" - no matches
are found, although the string is contained in the file, as verified by
grep or strings.

Version-Release number of selected component (if applicable):
less-394-1.fc4
Comment 1 Jindrich Novy 2006-01-28 02:27:17 EST
Upstream claims this bug has been fixed since less-376, what's apparently not
true. I send email to Mark Nudelman about this.

FYI:

http://www.greenwoodsoftware.com/less/bugs.html
look for bug #179
Comment 2 Jindrich Novy 2006-01-30 10:54:04 EST
Mark replied this is actually caused by the bug #174 which is still open. less
cometimes fails to find strings to which '\0' is preceded.
Comment 3 Ivana Varekova 2006-02-15 06:07:13 EST
Fixed in less-394-3. 

Note You need to log in before you can comment on or make changes to this bug.