Bug 178808 - High system load.
High system load.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 10:22 EST by Philippe Rigault
Modified: 2013-03-05 22:44 EST (History)
3 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 14:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Rigault 2006-01-24 10:22:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux; en_US, fr) KHTML/3.5.0 (like Gecko)

Description of problem:
My 4-CPU system reports a very high load although it runs no particular  
program and should have a load of 0.0.  
  
I am not sure about the component being hal, it might be kernel.    
   
The system is running rawhide as of 2006-01-23 (fc5test2 would not install,  
see bug#178130).  
  
SunFire 4200       
Two Dual-core AMD Opteron Model 275 (2.2 GHz)  <- Seen as 4-CPU by Linux     
4GB RAM       
LSI Logic SAS1064 controller       
Two 2.5" hard disks: Seagate ST973401 73.4 GB - Ultra320 SCSI      
      

Version-Release number of selected component (if applicable):
hal-0.5.6-2,  kernel-2.6.15-1.1869_FC5

How reproducible:
Always

Steps to Reproduce:
 
     

Actual Results:  The system, with no particular program running, shows a high load of ~1.80  
accoring to 'top'.  
  top - 10:12:06 up 19:26,  1 user,  load average: 1.75, 1.81, 1.80   
Tasks: 111 total,   1 running, 110 sleeping,   0 stopped,   0 zombie   
Cpu0  :  0.0% us,  1.1% sy,  0.0% ni, 98.9% id,  0.0% wa,  0.0% hi,  0.0% si   
Cpu1  :  1.1% us,  1.1% sy,  0.0% ni, 97.7% id,  0.0% wa,  0.0% hi,  0.0% si   
Cpu2  :  0.0% us,  0.0% sy,  0.0% ni, 100.0% id,  0.0% wa,  0.0% hi,  0.0% si   
Cpu3  :  0.0% us,  0.0% sy,  0.0% ni, 100.0% id,  0.0% wa,  0.0% hi,  0.0% si   
Mem:   3988244k total,  3164912k used,   823332k free,   124836k buffers   
Swap:  4096532k total,        0k used,  4096532k free,  2813628k cached   
   
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND   
  683 test      16   0  7348 1072  804 R    2  0.0   0:00.09 top   
 2664 root      17   0  7284  820  704 S    1  0.0   0:01.45 hald-addon-stor   
 2685 root      17   0  7288  816  700 S    1  0.0   0:03.18 hald-addon-stor   
    1 root      16   0  7120  656  552 S    0  0.0   0:01.51 init   
    2 root      RT   0     0    0    0 S    0  0.0   0:00.05 migration/0   
    3 root      34  19     0    0    0 S    0  0.0   0:03.25 ksoftirqd/0   
    4 root      RT   0     0    0    0 S    0  0.0   0:00.00 watchdog/0   
    5 root      RT   0     0    0    0 S    0  0.0   0:00.08 migration/1   
    6 root      34  19     0    0    0 S    0  0.0   0:00.06 ksoftirqd/1   
    7 root      RT   0     0    0    0 S    0  0.0   0:00.00 watchdog/1   
    8 root      RT   0     0    0    0 S    0  0.0   0:00.04 migration/2   
    9 root      34  19     0    0    0 S    0  0.0   0:00.01 ksoftirqd/2   
   10 root      RT   0     0    0    0 S    0  0.0   0:00.00 watchdog/2   
   11 root      RT   0     0    0    0 S    0  0.0   0:00.19 migration/3   
   12 root      34  19     0    0    0 S    0  0.0   0:02.21 ksoftirqd/3   
   13 root      RT   0     0    0    0 S    0  0.0   0:00.00 watchdog/3   
   14 root      10  -5     0    0    0 S    0  0.0   0:00.00 events/0   
   15 root      10  -5     0    0    0 S    0  0.0   0:00.00 events/1   
   16 root      10  -5     0    0    0 S    0  0.0   0:00.00 events/2   
   17 root      10  -5     0    0    0 S    0  0.0   0:00.00 events/3   
   18 root      10  -5     0    0    0 S    0  0.0   0:00.00 khelper   
   19 root      10  -5     0    0    0 S    0  0.0   0:00.00 kthread   
   26 root      10  -5     0    0    0 S    0  0.0   0:00.00 kblockd/0   
   27 root      10  -5     0    0    0 S    0  0.0   0:00.00 kblockd/1   
   28 root      10  -5     0    0    0 S    0  0.0   0:00.00 kblockd/2   
   29 root      10  -5     0    0    0 S    0  0.0   0:00.00 kblockd/3   
   30 root      11  -5     0    0    0 S    0  0.0   0:00.00 kacpid   
  125 root      10  -5     0    0    0 S    0  0.0   0:00.00 khubd   
  196 root      15   0     0    0    0 S    0  0.0   0:00.67 pdflush   
  197 root      15   0     0    0    0 S    0  0.0   0:00.46 pdflush   
  198 root      17   0     0    0    0 S    0  0.0   0:00.00 kswapd1   
  199 root      17   0     0    0    0 S    0  0.0   0:00.00 kswapd0   
  200 root      12  -5     0    0    0 S    0  0.0   0:00.00 aio/0   
  201 root      10  -5     0    0    0 S    0  0.0   0:00.00 aio/1   
  202 root      12  -5     0    0    0 S    0  0.0   0:00.00 aio/2   
  203 root      10  -5     0    0    0 S    0  0.0   0:00.00 aio/3   
  280 root      10  -5     0    0    0 S    0  0.0   0:00.00 kseriod   
  348 root      10  -5     0    0    0 S    0  0.0   0:00.00 kpsmoused   
  392 root      11  -5     0    0    0 S    0  0.0   0:00.00 scsi_eh_0   
 

Expected Results:  Load close to zero when machine is idle.  

Additional info:

It seems that there are plenty of hald-addon-storage processes.  
  
$ ps auxww|grep [h]ald-addon-stor  
root      2661  0.0  0.0   7288   820 ?        S    Jan23   0:01  
hald-addon-storage  
root      2664  0.0  0.0   7284   820 ?        S    Jan23   0:01  
hald-addon-storage  
root      2667  0.0  0.0   7288   820 ?        S    Jan23   0:01  
hald-addon-storage  
root      2670  0.0  0.0   7288   824 ?        S    Jan23   0:01  
hald-addon-storage  
root      2673  0.0  0.0   7284   816 ?        S    Jan23   0:01  
hald-addon-storage  
root      2676  0.0  0.0   7284   820 ?        S    Jan23   0:01  
hald-addon-storage  
root      2679  0.0  0.0   7284   820 ?        S    Jan23   0:01  
hald-addon-storage  
root      2682  0.0  0.0   7288   820 ?        D    Jan23   0:01  
hald-addon-storage  
root      2685  0.0  0.0   7288   816 ?        S    Jan23   0:03  
hald-addon-storage  
root      2699  0.0  0.0   7284   812 ?        S    Jan23   0:06  
hald-addon-storage
Comment 1 Philippe Rigault 2006-01-25 12:05:06 EST
Killing all the hald-addon-storage processes brings back the load to 0.0. 
These processed do not seem to be respawned after killing them. 
 
Comment 2 Rahul Sundaram 2006-02-20 06:33:06 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 Red Hat Bugzilla 2007-02-05 14:34:58 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 4 Philippe Rigault 2007-02-05 14:48:29 EST
Closing, as fixed.
The system has been working fine with subsequent releases (FC5t3, FC5, and now 
FC6).

Note You need to log in before you can comment on or make changes to this bug.