Bug 178812 - ccsd needs more information in certain failure cases
ccsd needs more information in certain failure cases
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: ccs (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Abhijith Das
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 10:29 EST by Corey Marthaler
Modified: 2009-04-16 15:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0554
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:15:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for bz 178812 (574 bytes, patch)
2006-02-02 11:08 EST, Abhijith Das
no flags Details | Diff

  None (edit)
Description Corey Marthaler 2006-01-24 10:29:19 EST
Description of problem:
I'd be a little frustrated if I were the customer in this case.

[root@taft-01 ~]# service ccsd start
Starting ccsd:                                             [FAILED]

From the console:
Jan 24 09:27:15 taft-01 ccsd: startup failed

Not a whole lot to go on.

I then tried the ccsd cmd by myself and learned that I had a parsing error
[root@taft-01 ~]# ccsd
/etc/cluster/cluster.conf:3: parser error : Opening and ending tag mismatch:
cluster line 2 and cman
                </cman>
                       ^

# it should have been "<cman/>"
Comment 1 Abhijith Das 2006-02-02 11:08:00 EST
Created attachment 124051 [details]
fix for bz 178812

Changed to use 'action' command. Spits out any errors it encounters.
Comment 2 David Duffey 2006-02-10 10:12:58 EST
ccsd daemon should probably also be updated to give a textual error message.

For example, I did not install "magma-plugins" which is required for ccsd to
start but is not set as a dependency in RPM (there is another bugzilla that says
it is by design).

So, even a "ccsd -n" simply exits without any information except to return an
error code.  A simple message of "magma plugins not found" would help customers
realize their mistake.
Comment 3 Jonathan Earl Brassow 2006-02-15 13:38:06 EST
prompt> ccsd

has always given textual error messages.  However, it seems that

prompt> ccsd -n

has not been.  Although, the exit code (2) gives a good indication of the
problem - but users will not know what the exit code means...
Comment 4 Abhijith Das 2006-02-16 15:19:20 EST
fixed ccsd init script and ccsd daemon to print error messages. fix in CVS;
RHEL4, HEAD and STABLE
Comment 7 Red Hat Bugzilla 2006-08-10 17:15:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0554.html

Note You need to log in before you can comment on or make changes to this bug.