This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 178822 - Should mv always preserve selinux contexts (esp. nfs_t)?
Should mv always preserve selinux contexts (esp. nfs_t)?
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 12:18 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 11:49:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-01-24 12:18:36 EST
Description of problem:
Not really sure what is best here, but figured an open discussion would be good.
 It looks like mv preserves selinux contexts now, which is good for the most
part.  The issue I'm running into is users moving files from an nfs mount (which
has context nfs_t) into their local directories.  These directories are backed
up by amanda, but amanda doesn't not have permission for nfs_t (a good thing by
default), so these files don't get backed up.  I would guess that some kind of
exclusion list in mv would be unmaintainable.  Perhaps the best fix is for the
nfs mounts to show the contexts on the source system?  Will this ever happen?

Other suggestions?
Comment 1 Tim Waugh 2006-01-24 12:41:24 EST
Adding dwalsh to CC.  Dan, what do you think?

Comment 2 Daniel Walsh 2006-01-25 11:46:29 EST
The goal is to eventually get XAttr support into NFS V3/V4.    Which would allow
us to label files over nfs correctly.

Note You need to log in before you can comment on or make changes to this bug.