Bug 178833 - Unconditional close of the program that was started by mc.ext in X11
Unconditional close of the program that was started by mc.ext in X11
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
: 178891 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 13:01 EST by Andy Shevchenko
Modified: 2013-07-02 19:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 11:02:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Shevchenko 2006-01-24 13:01:04 EST
Description of problem:
When I click key on some file such as *.doc in the mc under X11 terminal the 
application is functionaling in background until mc did not closed.
In other words, oowriter started by following command line
   oowriter %f &
However, '> /dev/null 2>&1' should like to be substituted before '&'.

When I close mc I should not like to close background apps, such as oowriter or 
smth else.

Version-Release number of selected component (if applicable):
mc from last FC3/4 updates.

I think it may be implemented as patch to mc.ext file.
Comment 1 Andy Shevchenko 2006-01-25 06:09:03 EST
*** Bug 178891 has been marked as a duplicate of this bug. ***
Comment 2 Jindrich Novy 2006-01-25 06:24:45 EST
Yes, I agree that '>/dev/null 2>&1' should be added to the mc.ext file in order
to not to mess up the mc where an application from background is launched from.

However, I don't see that if I launch, say oowriter, in background that it
terminates when I quit mc it was launched from.
Comment 3 Jindrich Novy 2006-01-30 11:02:20 EST
I've added a few redirections to /dev/null in mc.ext.

Since I cannot reproduce your bug, I'm closing it NOTABUG.

Feel free to reopen it with proper reproduction case if you think you see a bug.
Comment 4 Andy Shevchenko 2006-01-31 08:58:00 EST
While now I also can not reproduce it. 
Ok. I agree with NOTABUG resolution.


P.S. If I discover the reproducable case of such behaviour I reopen this report.

Note You need to log in before you can comment on or make changes to this bug.