Bug 17884 - infinite loop on non-sufficient disk space
infinite loop on non-sufficient disk space
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-26 17:38 EDT by Michal Jaegermann
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 18:24:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2000-09-26 17:38:53 EDT
During an update of an existing RH 6.2 installation anacoda, in a text
mode, decides that is needs more space (fair enough if not nice) and
it goes into an infinite "prepare installation" loop without any
chance to intervene in other way but by a power switch.

What is more interesting that while it wanted an extra 251 MBytes
the first time subseqent requests are for 323 MB.  This is probably
caused by an extra copy of an installtion image.  I ended up with
on a root partition and another one in /usr.

  Michal
  michal@harddata.com
Comment 1 Michael Fulbright 2000-09-29 11:31:48 EDT
Please repeat with the final 7.0 release to verify this is still a problem. I
think we handled this issue after RC2.
Comment 2 Michael Fulbright 2000-09-29 14:41:21 EDT
I am including this comment from the user (unable to connect to Bugzilla due to
network problems):

   This was with Beta CDs for Alpha.  These CDs were made quite a bit later
   than RC2.  I have no idea if you transferred bug fixes from i386 to this
   set.

   Repeating the problem could be a bit difficult.  I had to reorganize
   my disk to finish an installation and I do not have now RH 6.2 with
   not enough space for an update.  Also final 7.0 for Alpha does not
   exist yet, AFAIK.
Comment 3 Michael Fulbright 2000-09-29 14:42:12 EDT
Sorry, I didn't catch this was on the Alpha - obviously you can't try the final
release out yet!
Comment 4 Brock Organ 2000-10-17 18:15:03 EDT
for the following scenario:

alpha miata minimum 6.2 install w/all disk space used (NO free space at all...)

upgrade to 7.0 using test tree 7.0-qa1017.0 fails with an rpm error right after
choosing to "Upgrade system" at the install type ... (rpm fails because there is
no space to upgrade the database) ...

fails with:

__db_assert:0 failed: file "/../dist/../common/db_err.c", line 200
install exited abnormally -- received signal 6

and then the install dies ...
Comment 5 Michal Jaegermann 2000-10-17 18:24:45 EDT
I think that you found another failure mode.  Note that in my case there
was enough space to put one installation image on a root partition, and
another one after the first failure on /usr, but it turned out that there
is not enough space left for all packages to install (an update) and that
triggered a looping with a power switch as the only "exit condition".

Note You need to log in before you can comment on or make changes to this bug.