Bug 178852 - Bad: Installer Hangs
Bad: Installer Hangs
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
https://www.redhat.com/archives/fedor...
:
: 178857 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 16:08 EST by Tony Chamberlain
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 18:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tony Chamberlain 2006-01-24 16:08:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
The URL I posted is one I found of someone with exactly the same problem.
Basically, trying to install FC4 on a Dell PowerEdge SC420 has a problem.
The X server locks up every time you install.

I installed in Text mode and the installation went fine.  All disks installed.
HOWEVER when it then tried to run X server it locked up again.

To sumamrize
1) Installing FC4 in graphical mode locks up almost right away
2) Installing FC4 in text mode installs OK but then it still locks up later on 
   when it tries to run X stuff.

A funny thing: when I test the disk it fails; however testing it on a different
machine (such as a Dimension) the disk passes.

I downloaded the most recent version of FC4 from the official web site.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to install FC4 on a Power Edge
2. Install with graphical mode, locks up very quickly
3.  Install with text mode locks up, much later but still does.
  

Actual Results:  It is necessary to reboot

Expected Results:  x server should have come up.

Additional info:

https://www.redhat.com/archives/fedora-list/2005-July/msg04497.html
show another user with the same probelm.  I tried to contact that user
but the mail failed.
Comment 1 Chris Lumens 2006-01-24 22:16:41 EST
*** Bug 178857 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2006-02-01 05:04:55 EST
Please upgrade your system to the latest Fedora Core 4 updates (which should
be done immediately after any fresh OS installation or upgrade), and run:

system-config-display --reconfig

Then try starting X.  If the problem still occurs, please update the bug report
with all details relevent to the problem, as the initial report is rather
vague.  More specifically, state the exact video hardware in the system, and
attach your X server log file and config file from the failed X server
attempt, along with the output of "lspci -vvn".

Please be sure that all file attachments should be uncompressed for browser
viewing.

Thanks in advance.
Comment 3 Tony Chamberlain 2006-02-02 16:18:59 EST
This is the most recent version of FC4.  I downloaded the most recent one
from the web site and put it on CD.  Is there a more current one?

Tony
Comment 4 Mike A. Harris 2006-02-03 02:27:27 EST
(In reply to comment #3)
> This is the most recent version of FC4.  I downloaded the most recent one
> from the web site and put it on CD.  Is there a more current one?

There is only one version of FC4 (or any Fedora release).  Once the CDs
are mastered, they are never remastered again, until the next OS release.

What I'm requesting above, is that you update your system with any new
packages which have been released as updates since Fedora Core 4 was
released.  That is done with the "yum" utility.  You'll need to update
your whole system by running "yum update", and then manually updating
the kernel:  "yum update kernel"

Then reboot into the new kernel.
Comment 5 Tony Chamberlain 2006-02-03 07:07:12 EST
I guess I am confused how I can update my system if it won't
install to begin with.  You need to have an installation running to do
yum update
Comment 6 Mike A. Harris 2006-02-03 07:36:16 EST
(In reply to comment #5)
> I guess I am confused how I can update my system if it won't
> install to begin with.  You need to have an installation running to do
> yum update

By doing a text mode installation, then updating, then configuring X, and
giving it a whirl

However, if text mode installation doesn't work, then you're experiencing
a non-X related bug during installation.  We don't release CD image updates
of Fedora Core releases however, so if you're totally unable to install
it in GUI or text mode, then unfortunately you can't install FC4 at all on
that system unless you can figure out how to work around the problem with
installer options, however that is outside the scope of bugzilla. (Bugzilla
isn't a help forum, however our mailing lists may be able to provide
assistance, troubleshooting, etc.)

To be clear, if there are any problems on the FC4 CD, which completely
prevent X based installation, even if we've fixed the problem in an FC
update, you cant use the fixed update to install the OS, as it isn't on
the CD image.

In order to diagnose the problem however, we definitely require an X server
log file and config file from a failed X session, either from the installer
itself, or from a post-install test.  Without any information to go on though,
there is no way to diagnose the problem.

Some other options that may or may not be suitable for you:

- try a test install of Fedora Core 5 test2 release (again, in text mode
  if necessary), and update to the latest devel packages.

- use a different video card, at least to perform the installation and
  updating

Hopefully one of these options will get you up and running, and able to
diagnose more of the problem, and provide the details we'd need to
assess the real problem if it is still present in the latest updates.

Hope this helps.
Comment 8 Mike A. Harris 2006-05-18 18:00:45 EDT
If this problem is still present in Fedora Core 5, with all available
updates applied, please file a bug report in X.Org bugzilla at
http://bugs.freedesktop.org in the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.


Note You need to log in before you can comment on or make changes to this bug.