Bug 178875 - NM uses strange IP address, doesn't seem to DHCP.
NM uses strange IP address, doesn't seem to DHCP.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 22:30 EST by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 02:25:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2006-01-24 22:30:45 EST
NM seems to be pulling IP addresses out of its ar^H^Hwossname instead of using
DHCP. Running with --no-daemon shows this...

NetworkManager: <information>   starting...
NetworkManager: <information>   eth0: Device is fully-supported using driver 'gem'.
NetworkManager: <information>   nm_device_new(): waiting for device's worker
thread to start
NetworkManager: <information>   nm_device_new(): device's worker thread started,
continuing.
NetworkManager: <information>   Now managing wired device 'eth0'.
NetworkManager: <information>   Deactivating device eth0.
NetworkManager: <information>   Found dial up configuration for Default via
Modem: GPRS
NetworkManager: <information>   Found dial up configuration for eftel via Modem:
eftel
NetworkManager: <information>   Found dial up configuration for AAISP via Modem:
AAISP
NetworkManager: <information>   Found dial up configuration for Worldcom via
Modem: Worldcom
NetworkManager: <information>   Updating allowed wireless network lists.
NetworkManager: <debug info>    [1138158207.102087]  (): New device added (hal u
di is '/org/freedesktop/Hal/devices/net_00_0a_95_f3_99_92').
NetworkManager: <information>   eth1: Device is fully-supported using driver '"b
cm43xx" driver 0.0.1'.
NetworkManager: <information>   nm_device_new(): waiting for device's worker thr
ead to start
NetworkManager: <information>   nm_device_new(): device's worker thread started,
 continuing.
NetworkManager: <information>   Now managing wireless device 'eth1'.
NetworkManager: <information>   Deactivating device eth1.
NetworkManager: <information>   SWITCH: no current connection, found better
connection 'eth1'.
NetworkManager: <information>   Will activate connection 'eth1/LCA06'.
NetworkManager: <information>   Device eth1 activation scheduled...
NetworkManager: <information>   Activation (eth1) started...
NetworkManager: <information>   Activation (eth1) Stage 1 (Device Prepare)
scheduled...
NetworkManager: <information>   Activation (eth1) Stage 1 (Device Prepare)
started...
NetworkManager: <information>   Activation (eth1) Stage 2 (Device Configure)
scheduled...
NetworkManager: <information>   Activation (eth1) Stage 1 (Device Prepare) complete.
NetworkManager: <information>   Activation (eth1) Stage 2 (Device Configure)
starting...
NetworkManager: <information>   Old device 'eth1' activating, won't change.
NetworkManager: <information>   Activation (eth1/wireless) Stage 2 (Device
Configure) will connect to access point 'LCA06'.
NetworkManager: <information>   Activation (eth1/wireless): access point 'LCA06'
is unencrypted, no key needed.
NetworkManager: <information>   Activation (eth1/wireless): using essid 'LCA06',
with no authentication.
NetworkManager: <information>   Activation (eth1/wireless) Stage 2 (Device
Configure) successful.  Connected to access point 'LCA06'.
NetworkManager: <information>   Activation (eth1) Stage 3 (IP Configure Start)
scheduled.
NetworkManager: <information>   Activation (eth1) Stage 2 (Device Configure)
complete.
NetworkManager: <information>   Activation (eth1) Stage 3 (IP Configure Start)
started...
NetworkManager: <information>   Activation (eth1) Stage 4 (IP Configure Get)
scheduled...
NetworkManager: <information>   Activation (eth1) Stage 3 (IP Configure Start)
complete.
NetworkManager: <information>   Activation (eth1) Stage 4 (IP Configure Get)
started...
NetworkManager: <information>   Activation (eth1) Stage 5 (IP Configure Commit)
scheduled...
NetworkManager: <information>   Activation (eth1) Stage 4 (IP Configure Get)
complete.
NetworkManager: <information>   Activation (eth1) Stage 5 (IP Configure Commit)
started...
NetworkManager: <information>   Your IP address = 144.135.211.117
NetworkManager: <information>   Activation (eth1) successful, device activated.
NetworkManager: <information>   Activation (eth1) Finish handler scheduled.
NetworkManager: <information>   Activation (eth1) Stage 5 (IP Configure Commit)
complete.
NetworkManager: <information>   FORCE: device
'/org/freedesktop/NetworkManager/Devices/eth1', network 'LCA06'
NetworkManager: <information>   Deactivating device eth1.
NetworkManager: compute_nameservers: assertion `config != NULL' failed


I don't know where it's getting '144.135.211.117' from, but it's wrong. Running
tcpdump seems to show that it's not getting it from DHCP. Recursive grep in /etc
for '144.135' doesn't seem to show anything.

Running 'dhclient eth1' gets a correct IP address.
Comment 1 David Woodhouse 2006-01-24 23:00:21 EST
User error -- that IP address was configured in
/etc/sysconfig/network-scripts/ifcfg-eth1 because of an unreliable DHCP server I
encountered last week.

But grrr.... if you can use /etc/sysconfig/network-scripts/ifcfg-eth1, why can't
you also use /etc/sysconfig/network-scripts/keys-eth1?
Comment 2 Dan Williams 2006-02-27 02:25:36 EST
Because keys are considered user-specific at this time, just like certificates
for WPA2 Enterprise and other stuff is...

For NM 0.7 there will be a system-wide config where you'll be able to mark
certain networks as "system wide".  Should also fix connect-on-startup and the
keyring dialog on login issues.

Note You need to log in before you can comment on or make changes to this bug.