This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 178881 - Ericsson K750i Phone flash drive missing if inserted in phone when connected, detected by udev
Ericsson K750i Phone flash drive missing if inserted in phone when connected,...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 00:40 EST by Henrik Nordstrom
Modified: 2013-03-13 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 02:10:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hotplug events in a failed session (5.74 KB, text/plain)
2006-01-25 01:03 EST, Henrik Nordstrom
no flags Details
hotplug events in a working session without the card inserted (5.58 KB, text/plain)
2006-01-25 01:04 EST, Henrik Nordstrom
no flags Details

  None (edit)
Description Henrik Nordstrom 2006-01-25 00:40:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
If the memory card is already inserted in the phone when the USB cable is connected the card slot and card is lost by hal. The device is hoever detected by udev and device nodes is properly created and can be mounted manually using mount.

Version-Release number of selected component (if applicable):
hal-0.5.6-2

How reproducible:
Always

Steps to Reproduce:
1. Ericsson K750i phone with Memory Stick Duo inserted
2. Connect USB cable
3. hal-device-info
  

Actual Results:  Both the card reader and the media missing in the hal-device output, and no icon shown on desktop.

Expected Results:  card reader and media should have been detected, and icon shown on desktop

Additional info:

no hal-addon-storage daemon gets started when the problem is seen.

"service haldaemon restart" makes hal properly detect the device, but does not cause the desktop icon to appear.

if the memory card is not inserted into the phone when the USB cable is connected then the card reader is detected by hal, and if later inserting the memory card it too is properly detected. Even removing the card works..


At all times does udev detect the card reader and sets up device nodes proper allowing access to the media. But somewhere along the path has the hal registration of the card reader and inserted media gone missing.
Comment 1 Henrik Nordstrom 2006-01-25 01:03:37 EST
Created attachment 123650 [details]
hotplug events in a failed session

Data collected using the following wrapper around hal-hotplug:

cd /etc/hotplug.d/default
mkdir disabled
mv 20-hal.hotplug disabled
cat >>20-hal.hotplug <<EOS
#!/bin/sh
echo $$ "`date`" "$@" >>/tmp/hotplug.log
env >>/tmp/hotplug.log
/etc/hotplug.d/default/disabled/20-hal.hotplug "$@"
echo $$ done >>/tmp/hotplug.log
EOS
chmod +x 20-hal.hotplug
Comment 2 Henrik Nordstrom 2006-01-25 01:04:18 EST
Created attachment 123651 [details]
hotplug events in a working session without the card inserted
Comment 3 Henrik Nordstrom 2006-01-25 01:19:34 EST
Same device on FC4 x86 works fine it seems. Have not tested on FC4 x86_64.
Comment 4 Henrik Nordstrom 2006-01-25 02:10:23 EST
got updated kernel-2.6.15-1.1871_FC5 and udev-078-6 packages from development
and now things works better. Probably the delay things added to udev which got
it working but a bit confusing that an upgrade of udev fixes hal when udev
didn't show any signs of problems in it's parts that could tell. Probably there
is some underlying issue in hal now worked around, but it's working so I am happy.

Was previously using kernel-2.6.15-1.1869_FC5 and udev-078-4

Note You need to log in before you can comment on or make changes to this bug.