Bug 178888 - New Customers can not get past the Terms and Conditions in RHN
Summary: New Customers can not get past the Terms and Conditions in RHN
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability   
(Show other bugs)
Version: unspecified
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: Beth Nackashi
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-25 08:28 UTC by Thomas "Shea" DeAntonio
Modified: 2007-10-24 02:47 UTC (History)
3 users (show)

Fixed In Version: 4.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-26 01:41:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas "Shea" DeAntonio 2006-01-25 08:28:30 UTC
Description of problem:
New customers that create accounts and then activate product can not get past
the terms and condition page the first time they log into RHN.


Version-Release number of selected component (if applicable):
RHN405


How reproducible:
Always.


Steps to Reproduce:
1.Create a new account.
2.Login to the account at rhn.redhat.com
3.Click on "I agree" on the terms and condition page.
  
Actual results:
Page gives and error."An error occurred while processing your acceptance of Red
Hat's Terms and Conditions of use. Please click on the link below to log back
into Red Hat Network and complete the acceptance process."

Customer is pushed out of RHN and logs in again with same results.


Expected results:
T%C are accepted and customers can then register systems for updates on RHN.


Additional info:

Comment 3 Max Spevack 2006-01-25 16:06:53 UTC
I tried as well with a "random" brand new account in prod, and had
no problems with T&C.

Comment 4 Todd Warner 2006-01-25 16:29:43 UTC
So far this is unreproducable by RHN QA and GSS.

Comment 8 Mike McCune 2006-01-25 23:19:49 UTC
We found the issue with some of the way the user data was being 
created in WWW and then fetched in RHN.

We resolved the data creation issue in WWW and ran a SQL script to
fix the existing accounts.

Please report back if this problem continues to exist because from
our testing and perspective it should be resolved.

Mike


Comment 9 Mike McCune 2006-01-26 01:41:40 UTC
Closing this bug.  Please re-open if this problem occurs again.


Note You need to log in before you can comment on or make changes to this bug.