Bug 178888 - New Customers can not get past the Terms and Conditions in RHN
New Customers can not get past the Terms and Conditions in RHN
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability (Show other bugs)
unspecified
All Linux
medium Severity high
: ---
: ---
Assigned To: Jesus M. Rodriguez
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 03:28 EST by Thomas "Shea" DeAntonio
Modified: 2007-10-23 22:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 20:41:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas "Shea" DeAntonio 2006-01-25 03:28:30 EST
Description of problem:
New customers that create accounts and then activate product can not get past
the terms and condition page the first time they log into RHN.


Version-Release number of selected component (if applicable):
RHN405


How reproducible:
Always.


Steps to Reproduce:
1.Create a new account.
2.Login to the account at rhn.redhat.com
3.Click on "I agree" on the terms and condition page.
  
Actual results:
Page gives and error."An error occurred while processing your acceptance of Red
Hat's Terms and Conditions of use. Please click on the link below to log back
into Red Hat Network and complete the acceptance process."

Customer is pushed out of RHN and logs in again with same results.


Expected results:
T%C are accepted and customers can then register systems for updates on RHN.


Additional info:
Comment 3 Max Spevack 2006-01-25 11:06:53 EST
I tried as well with a "random" brand new account in prod, and had
no problems with T&C.
Comment 4 Todd Warner 2006-01-25 11:29:43 EST
So far this is unreproducable by RHN QA and GSS.
Comment 8 Mike McCune 2006-01-25 18:19:49 EST
We found the issue with some of the way the user data was being 
created in WWW and then fetched in RHN.

We resolved the data creation issue in WWW and ran a SQL script to
fix the existing accounts.

Please report back if this problem continues to exist because from
our testing and perspective it should be resolved.

Mike
Comment 9 Mike McCune 2006-01-25 20:41:40 EST
Closing this bug.  Please re-open if this problem occurs again.

Note You need to log in before you can comment on or make changes to this bug.