Bug 178911 - snmpset commands are not working on FC4 ia64, but do work on FC4 i386
snmpset commands are not working on FC4 ia64, but do work on FC4 i386
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 08:15 EST by Martijn
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 03:23:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martijn 2006-01-25 08:15:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
I am using snmpset with FC4 ia64 release to upgrade DOCSIS cable modems to newer firmware. This is done by setting several SNMP OID's. See attachment for
When I issue the commands on an ia64 distribution, the modem won't upgrade.
When I issue the commands on an i386 distribution, the modem does upgrade.
Both installations are full installation out of the box configurations.
When I remove all 64bit net-snmp and sqlite packages and reinstall the 32-bit versions (see attachment for details) the snmpset commands do work again now

Attachment:

my workaround which 'fixed' the problem:

* procedure to get snmpset working again for modem firmware upgrades
  for x86_64 distributions; i386 is working fine out of the box:

        * remove all net-snmp packages from existing FC4 default release x86_64 installation:
        rpm -e --nodeps net-snmp-libs-5.2.1-12
        rpm -e --nodeps net-snmp-5.2.1-12
        rpm -e --nodeps net-snmp-libs-5.2.1-12
        rpm -e --nodeps net-snmp-utils-5.2.1-12
        rpm -e --nodeps net-snmp-devel-5.2.1-12
        rpm -e --nodeps net-snmp-perl-5.2.1-12

        * download and install all FC4 default release i386 net-snmp packages:
        rpm -ivh --force --nodeps net-snmp-5.2.1-12.i386.rpm
        rpm -ivh --force --nodeps net-snmp-devel-5.2.1-12.i386.rpm
        rpm -ivh --force --nodeps net-snmp-libs-5.2.1-12.i386.rpm
        rpm -ivh --force --nodeps net-snmp-perl-5.2.1-12.i386.rpm
        rpm -ivh --force --nodeps net-snmp-utils-5.2.1-12.i386.rpm

        * download and update all FC4 default release rpm-* packages
        rpm -Uvh --force --nodeps rpm-4.4.1-21.x86_64.rpm
        rpm -Uvh --force --nodeps rpm-build-4.4.1-21.x86_64.rpm
        rpm -Uvh --force --nodeps rpm-devel-4.4.1-21.x86_64.rpm
        rpm -Uvh --force --nodeps rpm-libs-4.4.1-21.i386.rpm
        rpm -Uvh --force --nodeps rpm-libs-4.4.1-21.x86_64.rpm
        rpm -Uvh --force --nodeps rpm-python-4.4.1-21.x86_64.rpm

        * remove all sqlite packages from existing FC4 default release x86_64 installation:
        rpm -e --nodeps sqlite-3.1.2-3.i386.rpm
        rpm -e --nodeps sqlite-3.1.2-3

        * copy /usr/lib64/libsqlite3.so.0 from an working FC4 default release machine to
        the /usr/lib64 directory:
        cp libsqlite3.so.0 /usr/lib64/

        * install FC4 default release sqlite* i386 packages again:
        rpm -ivh sqlite-3.1.2-3.i386.rpm
        rpm -ivh sqlite-devel-3.1.2-3.i386.rpm

        Now snmpset is working again for modem firmware upgrades!


screen output of the commands issued to the cable modem:

# retrieve current firmware:
snmpget -v2c -c biG=d0tcat 10.182.28.159 1.3.6.1.2.1.69.1.3.5.0
SNMPv2-SMI::mib-2.69.1.3.5.0 = STRING: "ST52.03.16"

# upgrade commands to upgrade the cable modem:
snmpget -v2c -c private 10.182.28.159 1.3.6.1.2.1.69.1.3.5.0
SNMPv2-SMI::mib-2.69.1.3.5.0 = STRING: "ST52.03.16"
snmpset -v2c -c private 10.182.28.159 mib-2.69.1.3.1.0 a 212.142.39.132
SNMPv2-SMI::mib-2.69.1.3.1.0 = IpAddress: 212.142.39.132
snmpset -v2c -c private 10.182.28.159 mib-2.69.1.3.2.0 s DCM425_ST52_03_16-Euro.img
SNMPv2-SMI::mib-2.69.1.3.2.0 = STRING: "DCM425_ST52_03_16-Euro.img"
snmpset -v2c -c private 10.182.28.159 mib-2.69.1.3.3.0 i 1

screen output of the working i386 distribution and ia64 distribution is exactly the same. However, the modem will not upgrade with 64-bit packages.


Version-Release number of selected component (if applicable):
all net-snmp rpm's of default FC4 ia64 distribution (5.2.1-12)

How reproducible:
Always

Steps to Reproduce:
1. install ia64 FC4 full install / out of the box configuration
2. issue snmpset commands, see above
3. modem does not upgrade on ia64, modem does upgrade on i386 distribution/i386 installed net-snmp components.
  

Actual Results:  screen output for non working 64-bit version is exactly the same as 32-bit packages, but modem is not upgrading it's software on 64-bit distribution, while 32-bit pakages are making the modem to upgrade.

Expected Results:  modems should be upgraded to newer firmware.

Additional info:
Comment 1 Radek Vokal 2006-01-26 03:26:29 EST
Hmm, I'm not sure I can reproduce the issue here. Also I wonder how it is
connected with sqlite. There's dependency between net-snmp and sqlite through
rpmdb, but it's only for quering rpm packages. 

So you say it's fixed when you install 32bit sqlite package on 64bit machine but
you keep the 64bit lib file? That's weird :) 

Would be great if you can try to build net-snmp-5.2 from rawhide on your FC4 box
and see if it's fixed. Probably it will need to recompile all stuff which
requires libnetsnmp (or creating a symlink to old lib version). 
Comment 2 Martijn 2006-01-26 03:57:29 EST
I've installed both net-snmp 32bit and sqlite 32bit; I did not try to just 
install net-snmp 32bit and keep sqlite 64bit. I will verify this on a freshly 
installed 64bit server asap.

I will also try to build net-snmp-5.2 from rawhide. 

Keep you posted.
Comment 3 Martijn 2006-01-27 03:08:23 EST
Thanks for the hint, I've recompiled the latest source rpm of the rawhide 
directory and the snmpset is working again!
I'll do the same for the php-snmp packages, since that seemed not to work 
either.
You can close the bug report I guess.
Maybe it's possible to release an updated packages in the updates directory 
for Fedora Core 4, to eliminate the bug?
thanks again.
Comment 4 Radek Vokal 2006-01-27 03:23:06 EST
Probably there won't be update to 5.3 in FC4 as it would need recompiling all
net-snmp dependent packages and finding a patch to make this work would be a pain :)

Note You need to log in before you can comment on or make changes to this bug.