This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 178927 - ext2online will not extend ext2 filesystem without journal
ext2online will not extend ext2 filesystem without journal
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Jay Turner
:
Depends On:
Blocks: 248673
  Show dependency treegraph
 
Reported: 2006-01-25 10:41 EST by David Lawrence
Modified: 2015-01-07 19:11 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0758
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:00:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2006-01-25 10:41:56 EST
Description of problem:
When resizing an ext2 filesystem on an extended LVM logical volume, I get the
following error message:

[root@station6 ~]# ext2online /dev/test0/scratch
ext2online v1.1.18 - 2001/03/18 for EXT2FS 0.5b
ext2online: ext2_ioctl: Inappropriate ioctl for device

ext2online: unable to resize /dev/mapper/test0-scratch

I used the following to make the ext2 filesystem originally:

mke2fs /dev/test0/scratch

If I had create the filesystem originally with the -j option (ext3) then
the online resize works fine. This error occurs with the latest e2fsprogs 
errata  package.

e2fsprogs-1.35-11.6.EL4

Note: There is a discussion related to this that claims the documention is wrong
 and that ext3 is the only support filesystem type for this. So if ext2online is
not supposed to work for ext2 then it should be reflected in the docs.

http://archives.free.net.ph/message/20050304.181417.232a2b24.en.html
Comment 1 Stephen Tweedie 2006-02-03 15:23:06 EST
Agreed that this needs documented; we are unlikely to implement online resize
for ext2.
Comment 3 RHEL Product and Program Management 2007-05-09 06:55:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Don Domingo 2007-08-01 22:17:28 EDT
thanks Linda, adding to RHEL4.6 release notes under "Known Issues":

<quote>
At present, ext2online does not work for EXT2 file systems.
</quote>

please advise if any revisions are necessary. thanks!
Comment 6 Eric Sandeen 2007-08-30 14:02:47 EDT
I'll update the man page for this, too.
Comment 7 Eric Sandeen 2007-08-30 14:46:35 EDT
Ok, I've got the manpage change done, sorry, should have happened long ago.
Comment 8 Don Domingo 2007-08-30 22:58:25 EDT
adding "TIP" to RHEL4 System Admin Guide:

<quote>
You can increase the size of an ext3 file system using ext2online. ext2online
allows you to increase the size of an ext3 file system once it is mounted
(online) and on a resizable logical volume. The root file system is set up by
default on LVM2 logical volumes during installation.
		
Note that ext2online will only work on ext3 file systems. For more information,
refer to man ext2online.
</quote>

please advise if any revisions are necessary. thanks!
Comment 12 Eric Sandeen 2007-09-20 14:09:06 EDT
Whoops, this should be in MODIFIED.

Committed & built for e2fsprogs-1.35-12.11.el4
Comment 16 errata-xmlrpc 2007-11-15 11:00:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0758.html
Comment 17 Eric Sandeen 2008-04-07 11:33:34 EDT
In the relnotes:

Known Issues

    * At present, ext2online does not work for EXT2 file systems.

I'm not sure this needs a relnote like this; ext2online, strangely enough, was
never designed to resize ext2 filesystems, and there are no plans to add the
functionality.   The man page has been updated to reflect this understandable
misconception... :)

So I'm not sure this really needs to be flagged as an "issue" since it's really
just a clarification of the original design intent?

Thanks,
-Eric
Comment 18 Don Domingo 2008-04-08 02:04:08 EDT
Thanks Eric. that note was actually also included in the RHEl4.7 release notes
(we normally move over all known issues from previous release notes, and just
edit as we go); i've removed it now.

Note You need to log in before you can comment on or make changes to this bug.