Bug 178993 - js-devel does not contain pc file
js-devel does not contain pc file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: js (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
http://bugs.debian.org/344604
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 03:03 EST by Julian Sikorski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 07:40:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2006-01-26 03:03:30 EST
This causes problems with gxine since version 0.5.4. Have a look at the debian
bugreport, the pc file is attached there.
Comment 1 Matthias Saou 2006-01-26 11:38:21 EST
The next FC development package will have this .pc file included, and it has now
been updated to the final 1.5 release too. If you could try it out and tell me
if it looks okay, I could then backport the package to FC4.
Comment 2 Julian Sikorski 2006-01-26 15:12:40 EST
You mean the one from extras-development repo? I can test it after it's released.
Comment 3 Matthias Saou 2006-01-27 07:03:14 EST
Yes, it's the js-1.5-1.fc5 build, which should appear after the next push happens.
Comment 4 Julian Sikorski 2006-01-29 04:34:59 EST
Hmm, I have downloaded js and js-devel. I had to install them with nodeps swithc
due to unsatisfied dependencies with perl and libc.so.6 (the latter is actually
present on my system). The gxine build has failed:
gcc -DHAVE_CONFIG_H -I. -I. -I../include -I../include -I../include
-I/usr/include -I../pixmaps    -std=gnu99 -I/usr/include -I/usr/X11R6/include
-DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0
-I/usr/include/pango-1.0 -I/usr/include/freetype2
-I/usr/include/freetype2/config -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -pthread -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include   -I   -DLOCALEDIR=\"/usr/share/locale\" -O2 -g
-pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4
-fasynchronous-unwind-tables -c `test -f 'menu.c' || echo './'`menu.c
main.c: In function 'gxine_try_remote':
main.c:108: warning: ignoring return value of 'getcwd', declared with attribute
warn_unused_result
main.c: In function 'main':
main.c:296: error: 'LOCALEDIR' undeclared (first use in this function)
main.c:296: error: (Each undeclared identifier is reported only once
main.c:296: error: for each function it appears in.)
mediamarks.c: In function 'load_old_file':
mediamarks.c:311: warning: ignoring return value of 'sscanf', declared with
attribute warn_unused_result
make[1]: *** [main.o] Error 1
make[1]: *** Waiting for unfinished jobs....
mediamarks.c: At top level:
mediamarks.c:730: warning: initialization from incompatible pointer type
mediamarks.c:731: warning: initialization from incompatible pointer type
mediamarks.c:732: warning: initialization from incompatible pointer type
mediamarks.c:733: warning: initialization from incompatible pointer type
mediamarks.c:734: warning: initialization from incompatible pointer type
mediamarks.c:735: warning: initialization from incompatible pointer type
mediamarks.c:736: warning: initialization from incompatible pointer type
make[1]: Leaving directory `/home/xxx/rpmbuild/BUILD/gxine-0.5.4/src'
make: *** [all-recursive] Error 1
I'll ask in the xine mailing list.
Comment 5 Julian Sikorski 2006-01-29 15:09:24 EST
Well, the pkgconfig file seems to be broken. It most probably should have
something after -I.
Comment 6 Julian Sikorski 2006-01-29 16:23:52 EST
Here is the patch by Darren Salt:

--- js-1.5-1.fc5/js.spec~	2006-01-29 20:35:13.000000000 +0000
+++ js-1.5-1.fc5/js.spec	2006-01-29 20:35:13.000000000 +0000
@@ -48,7 +48,7 @@
 %{__cp} src/perlconnect/README.html src/README.perlconnect.html
 
 # Create pkgconfig file
-%{__cat} > libjs.pc << EOF
+%{__cat} > libjs.pc <<'EOF'
 prefix=%{_prefix}
 exec_prefix=${_prefix}
 libdir=${_libdir}
Comment 7 Matthias Saou 2006-01-30 04:52:47 EST
Major boo-boo on my part indeed, thanks for spotting this! I'll push a fixed
rebuild for FC development now.
Comment 8 Julian Sikorski 2006-02-01 04:35:43 EST
Everything works now, you can backport it to fc4 now.
Comment 9 Matthias Saou 2006-02-03 07:40:23 EST
Backported, built, and now available!

Note You need to log in before you can comment on or make changes to this bug.