Bug 178999 - Cups it dies with "segfault" and "general protection"
Summary: Cups it dies with "segfault" and "general protection"
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cups   
(Show other bugs)
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 189230 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-26 11:46 UTC by Nuno Dias
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 13:03:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb output (8.73 KB, text/plain)
2006-01-26 14:12 UTC, Nuno Dias
no flags Details
gdb output from cups crash (8.93 KB, text/plain)
2006-02-23 15:18 UTC, Nuno Dias
no flags Details
lpstat output (2.06 KB, text/plain)
2006-02-23 17:42 UTC, Nuno Dias
no flags Details

Description Nuno Dias 2006-01-26 11:46:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
The daemon of cups it dies randomly.

I have this logs in /var/log/messages

Jan 24 10:58:25 lnsys06 kernel: cupsd[2275] general protection rip:55555555ec82
rsp:7ffffffc9fa0 error:0
Jan 24 15:08:49 lnsys06 kernel: cupsd[12871]: segfault at 0000646574726f70 rip 000055555555ec82 rsp 00007fffffe5b190 error 4
Jan 25 14:26:05 lnsys06 kernel: cupsd[24912] general protection rip:55555555ec82 rsp:7fffff9f9ea0 error:0


Version-Release number of selected component (if applicable):
cups-1.1.23-15.3

How reproducible:
Sometimes

Steps to Reproduce:
1. Start cups
2. wait for cups crash
3.
  

Actual Results:  The daemon of cups it dies.

Expected Results:  The daemon of cups not die.

Additional info:

Comment 1 Tim Waugh 2006-01-26 13:15:37 UTC
Works for me on x86_64, same n-v-r.

I'd like you to try to obtain some debugging information from cupsd.  First,
install this package:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/x86_64/debug/cups-debuginfo-1.1.23-15.3.x86_64.rpm

Now please try attaching gdb to cupsd before it dies, like:

gdb /usr/sbin/cupsd 12871

(but use the real PID instead of 12871)

Then, at the '(gdb)' prompt, type 'continue' and press enter.  When the daemon
dies, you should get another '(gdb)' prompt -- type 'bt' when this happens. 
What does it say?

Comment 2 Nuno Dias 2006-01-26 14:12:20 UTC
Created attachment 123715 [details]
gdb output

This is the output from gdb after cups dies.

Comment 3 Tim Waugh 2006-01-27 17:09:25 UTC
Please try this test package:

https://www.redhat.com/archives/fedora-test-list/2006-January/msg02058.html

Does it change the behaviour at all?

Comment 4 Nuno Dias 2006-02-07 13:36:11 UTC
After several days, there is no crashes, i think that the last packages have
resolved the problem.

Thank's

Comment 5 Tim Waugh 2006-02-07 14:04:53 UTC
Great.  Thanks for testing it out.

Comment 6 Nuno Dias 2006-02-23 15:18:16 UTC
Created attachment 125109 [details]
gdb output from cups crash

Comment 7 Nuno Dias 2006-02-23 15:20:35 UTC
After a couple of days with cups testing package (cups-1.1.23-15.4), I have the
same problems, cups die.
I upload a new gdb crash output.

Comment 8 Tim Waugh 2006-02-23 15:46:52 UTC
Could you attach your /etc/cups/printers.conf and /etc/cups/classes.conf files
please?

Comment 9 Nuno Dias 2006-02-23 16:49:54 UTC
That two files are the original's that came with the package, I use the
"Browsing" to see the printers in the network.

Comment 10 Tim Waugh 2006-02-23 17:03:18 UTC
Would you mind showing me the output of 'lpstat -c'?

Comment 11 Nuno Dias 2006-02-23 17:42:33 UTC
Created attachment 125118 [details]
lpstat output

This is the output from lpstat -c

Comment 12 Tim Waugh 2006-02-24 18:17:42 UTC
Reported upstream:
  http://www.cups.org/str.php?L1439

Comment 13 Tim Waugh 2006-04-18 17:46:54 UTC
*** Bug 189230 has been marked as a duplicate of this bug. ***

Comment 14 Tim Waugh 2006-04-18 17:47:49 UTC
I think that the updates-testing package of cups 1.2 should fix this problem. 
Please try it out.  Thanks.

Comment 15 Nuno Dias 2006-04-19 16:45:49 UTC
I have the same problems in others machines with arquitectura i386, but there is
no update-testing packages for cups in i386, it's possible to provides this
packages ? or i need to open another bug ?
Tahnk's

Comment 16 Nuno Dias 2006-04-20 14:08:22 UTC
The package cups-1.2-0.2.rc1.2.8 that i instaled from update-testing repository
have problems also.

This is the output from gdb 

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912532052048 (LWP 826)]
delete_rules (rules=0x72702f2f3a707069) at mime.c:439
439         if (rules->child != NULL)
(gdb) bt
#0  delete_rules (rules=0x72702f2f3a707069) at mime.c:439
#1  0x0000555555592f52 in mimeDeleteType (mime=Variable "mime" is not
available.) at mime.c:156
#2  0x000055555558b6f6 in cupsdDeletePrinter (p=0x55555571f8c0, update=Variable
"update" is not available.
)
    at printers.c:706
#3  0x0000555555571474 in cupsdSendBrowseList () at dirsvc.c:808
#4  0x0000555555573aff in main (argc=Variable "argc" is not available.
) at main.c:889



Comment 17 Tim Waugh 2006-12-15 12:33:45 UTC
Do you still see this in FC6?

Comment 18 Nuno Dias 2006-12-15 12:59:46 UTC
No, in FC6 I don't have this problem anymore.


Note You need to log in before you can comment on or make changes to this bug.