Bug 179029 - Crash in firefox when opening an mpg file from a link in evolution
Crash in firefox when opening an mpg file from a link in evolution
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 13:37 EST by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-17 09:17:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2006-01-26 13:37:05 EST
Description of problem:

I got this crash in the above situation, could be totem mozilla plugin related?

The strange thing is that there's a bunch of empty symbols here even though I do
have all debuginfo packages installed for the relevant modules.

The file I tried opening was this (I have no idea what it is yet so beware :)

http://www.adrants.com/images/Optiker.mpg

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208445264 (LWP 2965)]
0x024f752f in ?? ()

(gdb) thread apply all bt

Thread 7 (Thread -1256195168 (LWP 2992)):
#0  0x00a99402 in ?? ()
#1  0x0011a37c in ?? () from /lib/libpthread.so.0
#2  0x0093fff4 in pt_TimedWait (cv=0x940aff4, ml=0x940af90, timeout=Variable
"timeout" is not available.
)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptsynch.c:280
#3  0x00940cc5 in PR_WaitCondVar (cvar=0x940aff0, timeout=60000)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptsynch.c:407
#4  0x0043c135 in nsHostResolver::GetHostToLookup (this=0x940af30,
    result=0xb51ff434) at nsHostResolver.cpp:556
#5  0x0043c298 in nsHostResolver::ThreadFunc (arg=0x940af30)
    at nsHostResolver.cpp:641
#6  0x0094647a in _pt_root (arg=0xb52005d8)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptthread.c:220
#7  0x00117262 in start_thread (arg=0xb51ffba0) at pthread_create.c:261
#8  0x00c5314e in ?? () from /lib/libc.so.6

Thread 5 (Thread -1232098400 (LWP 2990)):
#0  0x00a99402 in ?? ()
#1  0x0011a37c in ?? () from /lib/libpthread.so.0
#2  0x0093fff4 in pt_TimedWait (cv=0x953197c, ml=0x9531918, timeout=Variable
"timeout" is not available.
)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptsynch.c:280
#3  0x00940cc5 in PR_WaitCondVar (cvar=0x9531978, timeout=60000)
---Type <return> to continue, or q <return> to quit---
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptsynch.c:407
#4  0x00411983 in nsIOThreadPool::ThreadFunc (arg=0x95318e8)
    at nsIOThreadPool.cpp:254
#5  0x0094647a in _pt_root (arg=0x9aaf0a8)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptthread.c:220
#6  0x00117262 in start_thread (arg=0xb68faba0) at pthread_create.c:261
#7  0x00c5314e in ?? () from /lib/libc.so.6

Thread 4 (Thread -1210655840 (LWP 2966)):
#0  0x00a99402 in ?? ()
#1  0x00c49c10 in *__GI___poll (fds=0xcaeff4, nfds=1, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x009426fe in PR_Poll (pds=0x940a050, npds=1, timeout=4294967295)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptio.c:3877
#3  0x00431e18 in nsSocketTransportService::Poll (this=0x9409b68,
    interval=0xb7d6d424) at nsSocketTransportService2.cpp:359
#4  0x00432217 in nsSocketTransportService::Run (this=0x9409b68)
    at nsSocketTransportService2.cpp:568
#5  0x00f733e2 in nsThread::Main (arg=0x94045d8) at nsThread.cpp:118
#6  0x0094647a in _pt_root (arg=0x9404658)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptthread.c:220
#7  0x00117262 in start_thread (arg=0xb7d6dba0) at pthread_create.c:261
#8  0x00c5314e in ?? () from /lib/libc.so.6
---Type <return> to continue, or q <return> to quit---

Thread 3 (Thread -1221215328 (LWP 2967)):
#0  0x00a99402 in ?? ()
#1  0x0011a37c in ?? () from /lib/libpthread.so.0
#2  0x0093fff4 in pt_TimedWait (cv=0x93d5834, ml=0x93d74d8, timeout=Variable
"timeout" is not available.
)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptsynch.c:280
#3  0x00940cc5 in PR_WaitCondVar (cvar=0x93d5830, timeout=2230)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptsynch.c:407
#4  0x00f75251 in TimerThread::Run (this=0x93d0d80) at TimerThread.cpp:318
#5  0x00f733e2 in nsThread::Main (arg=0x95a5a28) at nsThread.cpp:118
#6  0x0094647a in _pt_root (arg=0x95a5aa8)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptthread.c:220
#7  0x00117262 in start_thread (arg=0xb735bba0) at pthread_create.c:261
#8  0x00c5314e in ?? () from /lib/libc.so.6

Thread 2 (Thread -1232098400 (LWP 2968)):
#0  0x00a99402 in ?? ()
#1  0x0011a37c in ?? () from /lib/libpthread.so.0
#2  0x0093fff4 in pt_TimedWait (cv=0x953197c, ml=0x9531918, timeout=Variable
"timeout" is not available.
)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptsynch.c:280
#3  0x00940cc5 in PR_WaitCondVar (cvar=0x9531978, timeout=60000)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptsynch.c:407
#4  0x00411983 in nsIOThreadPool::ThreadFunc (arg=0x95318e8)
---Type <return> to continue, or q <return> to quit---
    at nsIOThreadPool.cpp:254
#5  0x0094647a in _pt_root (arg=0x9aaf0a8)
    at ../../.././mozilla/nsprpub/pr/src/pthreads/ptthread.c:220
#6  0x00117262 in start_thread (arg=0xb68faba0) at pthread_create.c:261
#7  0x00c5314e in ?? () from /lib/libc.so.6

Thread 1 (Thread -1208445264 (LWP 2965)):
#0  0x024f752f in ?? ()
#1  0x075cf690 in __FUNCTION__.3266 () from /lib/libdbus-1.so.2
#2  0x075e55d4 in ?? () from /lib/libdbus-1.so.2
#3  0xbfcad054 in ?? ()
#4  0x07591d31 in _dbus_type_reader_get_current_type (reader=0xbfcad1c4)
    at dbus-marshal-recursive.c:896
#5  0x024fa8b5 in ?? ()
#6  0xbfcad1c4 in ?? ()
#7  0xbfcad12c in ?? ()
#8  0xbfcad154 in ?? ()
#9  0x024fa78e in ?? ()
#10 0xbfcad12c in ?? ()
#11 0xbfcad0e0 in ?? ()
#12 0xbfcad118 in ?? ()
#13 0xbfcad1c4 in ?? ()
#14 0x00000001 in ?? ()
---Type <return> to continue, or q <return> to quit---q

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kjartan Maraas 2006-02-17 09:17:07 EST
Looks like it was the plugin crashing firefox. Closing.

Note You need to log in before you can comment on or make changes to this bug.