Bug 179030 - file-roller crashes after extracting archives (rar, zip, tar)
file-roller crashes after extracting archives (rar, zip, tar)
Status: CLOSED DUPLICATE of bug 179031
Product: Fedora
Classification: Fedora
Component: file-roller (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 13:46 EST by Denis
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 21:17:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis 2006-01-26 13:46:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Debug info :

Backtrace was generated from '/usr/bin/file-roller'

Using host libthread_db library "/lib/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1209107584 (LWP 30871)]
[New Thread -1218937952 (LWP 30902)]
0x002d6402 in __kernel_vsyscall ()
#0  0x002d6402 in __kernel_vsyscall ()
#1  0x00ae580b in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x055a839d in gnome_init_with_popt_table () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x0805f988 in dir_contains_one_object (path=0x0) at file-utils.c:140
#5  0x0806d82d in check_child (data=0x99ee840) at fr-process.c:765
#6  0x0021d0f0 in g_source_get_current_time () from /usr/lib/libglib-2.0.so.0
#7  0x0021ca43 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#8  0x0021fa83 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#9  0x0021fe2c in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#10 0x0707f04c in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x08072c77 in main (argc=) at main.c:220
#12 0x007b76b4 in __libc_start_main () from /lib/libc.so.6
#13 0x08053fd1 in _start ()

Thread 2 (Thread -1218937952 (LWP 30902)):
#0  0x002d6402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0085fc10 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x0021fab6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x0021fe2c in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x0041aa55 in link_set_io_thread () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x00238935 in g_thread_create_full () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00adf262 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x0086914e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread -1209107584 (LWP 30871)):
#0  0x002d6402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00ae580b in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x055a839d in gnome_init_with_popt_table () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x0805f988 in dir_contains_one_object (path=0x0) at file-utils.c:140
	dp = 

Version-Release number of selected component (if applicable):
File Roller 2.13.4, Gnome 2.13.x

How reproducible:
Always

Steps to Reproduce:
1. Open arichive with file-roller
2. Extraxt to any folder
3. After extracing archive (rar, zip, tar) file-roller crashes
  

Actual Results:  all archives extracted fine, only file-roller crashed


Additional info:
Comment 1 Rahul Sundaram 2006-01-27 21:17:02 EST

*** This bug has been marked as a duplicate of 179031 ***

Note You need to log in before you can comment on or make changes to this bug.