Bug 179031 - file-roller crashes after extracting archives (rar, zip, tar)
file-roller crashes after extracting archives (rar, zip, tar)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: file-roller (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 179030 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 13:47 EST by Denis
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 12:07:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis 2006-01-26 13:47:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:


Version-Release number of selected component (if applicable):
File Roller 2.13.4, Gnome 2.13.x

How reproducible:
Always

Steps to Reproduce:
1. Open arichive with file-roller
2. Extraxt to any folder
3. After extracing archive (rar, zip, tar) file-roller crashes
  

Actual Results:  all archives extracted fine, only file-roller crashed


Additional info:

Debug info :

Backtrace was generated from '/usr/bin/file-roller'

Using host libthread_db library "/lib/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1209107584 (LWP 30871)]
[New Thread -1218937952 (LWP 30902)]
0x002d6402 in __kernel_vsyscall ()
#0  0x002d6402 in __kernel_vsyscall ()
#1  0x00ae580b in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x055a839d in gnome_init_with_popt_table () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x0805f988 in dir_contains_one_object (path=0x0) at file-utils.c:140
#5  0x0806d82d in check_child (data=0x99ee840) at fr-process.c:765
#6  0x0021d0f0 in g_source_get_current_time () from /usr/lib/libglib-2.0.so.0
#7  0x0021ca43 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#8  0x0021fa83 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#9  0x0021fe2c in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#10 0x0707f04c in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x08072c77 in main (argc=) at main.c:220
#12 0x007b76b4 in __libc_start_main () from /lib/libc.so.6
#13 0x08053fd1 in _start ()

Thread 2 (Thread -1218937952 (LWP 30902)):
#0  0x002d6402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0085fc10 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x0021fab6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x0021fe2c in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x0041aa55 in link_set_io_thread () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x00238935 in g_thread_create_full () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00adf262 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x0086914e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread -1209107584 (LWP 30871)):
#0  0x002d6402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00ae580b in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x055a839d in gnome_init_with_popt_table () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x0805f988 in dir_contains_one_object (path=0x0) at file-utils.c:140
	dp =
Comment 1 Frank Arnold 2006-01-27 11:20:17 EST
Already fixed in GNOME CVS. See http://bugzilla.gnome.org/show_bug.cgi?id=328331
Comment 2 Rahul Sundaram 2006-01-27 21:17:11 EST
*** Bug 179030 has been marked as a duplicate of this bug. ***
Comment 3 Rahul Sundaram 2006-02-20 06:07:28 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 Christopher Aillon 2006-02-20 12:07:06 EST
Actually, this one really is fixed.  Re-resolving.

Note You need to log in before you can comment on or make changes to this bug.