Bug 179064 - system-config-printer pulls in 64 bit alchemist rpm
system-config-printer pulls in 64 bit alchemist rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
ppc64 Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 16:56 EST by Patrick Mansfield
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 19:44:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Mansfield 2006-01-26 16:56:05 EST
Description of problem: system-config-printer depends on alchemist, but it pulls
in the 64 bit version.

Version-Release number of selected component (if applicable):

system-config-printer-0.6.149-1

How reproducible: 

Always hit on install of system-config-printer on ppc64 system  .

Steps to Reproduce:
1. install system-config-printer
  
Actual results:

Startup of cups gives this error:
[root@elm3a48 ~]# /etc/init.d/cups restart
Stopping cups:                                             [  OK  ]
Starting cups: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import backend
  File "/usr/share/printconf/util/backend.py", line 43, in ?
    import cups_import
  File "/usr/share/printconf/util/cups_import.py", line 7, in ?
    from printconf_conf import *
  File "/usr/share/printconf/util/printconf_conf.py", line 590, in ?
    from pyalchemist import *
ImportError: No module named pyalchemist
                                                           [  OK  ]

Expected results:

No errors when starting cups.


Additional info:

Installing alchemist.ppc (32 bit version) fixes the above error.
Comment 1 Tim Waugh 2006-01-27 07:08:51 EST
What does this say?:

rpm -q --qf "%{name}-%{version}-%{release}.%{arch}\n" system-config-printer
Comment 2 Patrick Mansfield 2006-01-27 11:53:33 EST
(In reply to comment #1)
> What does this say?:
> 
> rpm -q --qf "%{name}-%{version}-%{release}.%{arch}\n" system-config-printer

It shows:

system-config-printer-0.6.149-1.ppc
Comment 3 Tim Waugh 2006-01-27 12:07:01 EST
That package has:

$ rpm -qp --requires system-config-printer-0.6.149-1.ppc.rpm |grep alchemist
alchemist >= 1.0.33
alchemist >= 1.0.33

What does 'rpm -e alchemist.ppc' say?
Comment 4 Patrick Mansfield 2006-01-27 12:13:07 EST
(In reply to comment #3)
> That package has:
> 
> $ rpm -qp --requires system-config-printer-0.6.149-1.ppc.rpm |grep alchemist
> alchemist >= 1.0.33
> alchemist >= 1.0.33
> 
> What does 'rpm -e alchemist.ppc' say?

Nothing, but ppc64 shows output:

[root@elm3a48 ~]# rpm -e alchemist.ppc
[root@elm3a48 ~]#
[root@elm3a48 ~]# rpm -e alchemist.ppc64
error: Failed dependencies:
        alchemist >= 1.0.33 is needed by (installed)
system-config-printer-0.6.149-1.ppc



Comment 5 Tim Waugh 2006-01-27 12:26:23 EST
system-config-printer is packaged no differently with alchemist than
system-config-mouse is (say) with rhpl.

Not a package bug.
Comment 6 Jeff Johnson 2006-01-27 19:44:41 EST
I'm a bit confused: rpm does not "pull in the 64 bit version" for any package. rpm does exactly what it's 
told to do.

If you have
   Requires: alchemist >= 1.0.33
and you have both the ppc/ppc64 packages with
   Provides: alchemist = 1.0.33
then yes, removal of the last occurence (i.e. the ppc64 version) of the Provides: will
complain with
   error: Failed dependencies:
        alchemist >= 1.0.33 is needed by (installed)

This is exactly what I expect to happen. Two packages with identical Provides: signify
identical functionality independent of ppc/ppc64 architecture.

That's called a "logical assertion", as implemented in rpm dependencies. If you wish different
behavior, then you will need to change the packaging.
Comment 7 Patrick Mansfield 2006-01-28 01:22:14 EST
(In reply to comment #6)
> I'm a bit confused: rpm does not "pull in the 64 bit version" for any package.
rpm does exactly what it's 
> told to do.
> 
> If you have
>    Requires: alchemist >= 1.0.33
> and you have both the ppc/ppc64 packages with
>    Provides: alchemist = 1.0.33
> then yes, removal of the last occurence (i.e. the ppc64 version) of the
Provides: will
> complain with
>    error: Failed dependencies:
>         alchemist >= 1.0.33 is needed by (installed)
> 
> This is exactly what I expect to happen. Two packages with identical Provides:
signify
> identical functionality independent of ppc/ppc64 architecture.
> 
> That's called a "logical assertion", as implemented in rpm dependencies. If
you wish different
> behavior, then you will need to change the packaging.

The problem is not on removal, but when installing system-config-printer yum
installs alchemist.ppc64, rather than the alchemist.ppc.

What package should be changed to fix the problem?

[root@elm3a48 RPMS]# rpm -q --provides -p ./alchemist-1.0.36-1.1.ppc.rpm
warning: ./alchemist-1.0.36-1.1.ppc.rpm: Header V3 DSA signature: NOKEY, key ID
30c9ecf8
_alchemistmodule.so
libalchemist.so.0
libforgeblackbox.so.0
pyalchemist.so
alchemist = 1.0.36-1.1
[root@elm3a48 RPMS]# rpm -q --provides -p ./alchemist-1.0.36-1.1.ppc64.rpm
warning: ./alchemist-1.0.36-1.1.ppc64.rpm: Header V3 DSA signature: NOKEY, key
ID 30c9ecf8
_alchemistmodule.so()(64bit)
libalchemist.so.0()(64bit)
libforgeblackbox.so.0()(64bit)
pyalchemist.so()(64bit)
alchemist = 1.0.36-1.1

[root@elm3a48 RPMS]# rpm -q -R -p ./system-config-printer-0.6.149-1.ppc.rpm  |
grep alchemist
alchemist >= 1.0.33
alchemist >= 1.0.33


Note You need to log in before you can comment on or make changes to this bug.