Bug 179078 - X crashes on graphical install; text install almost unusable
X crashes on graphical install; text install almost unusable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 20:47 EST by Jay Cliburn
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-26 21:10:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Graphical install error (44.00 KB, image/jpeg)
2006-01-26 20:49 EST, Jay Cliburn
no flags Details
Text install problem (38.71 KB, image/jpeg)
2006-01-26 20:51 EST, Jay Cliburn
no flags Details
Odd color of installation first page. (52.20 KB, image/jpeg)
2006-01-26 21:06 EST, You, Yongkang
no flags Details

  None (edit)
Description Jay Cliburn 2006-01-26 20:47:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Installing FC5T2 (cd, sha1sum good, media check good) on a Dell Optiplex GX110 desktop with Intel 810 onboard graphics results in a failed attempt to start X with the error:

mini-wm: Fatal IO error 104 (Connection reset by peer) on X server :1.0. 

Installing with 'linux text' and 'linux text nofb' boot params results in misplaced text and garbage characters.  The onboard graphics adapter is properly detected, but the (Dell) monitor is not.

I aborted the install, leaving FC4 on the machine.

This bug is very similar to, if not exactly the same as, bug 178762, but my hardware is vastly different, hence the separate bug report.

I will add jpg images of the error shortly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install FC5T2 disk 1 (cd)
2.  Boot
3.
  

Actual Results:  See attached jpg images.

Expected Results:  I expect to be presented with normal X-window or ncurses screens during the installation process.

Additional info:
Comment 1 Jay Cliburn 2006-01-26 20:49:47 EST
Created attachment 123760 [details]
Graphical install error
Comment 2 Jay Cliburn 2006-01-26 20:51:12 EST
Created attachment 123761 [details]
Text install problem
Comment 3 You, Yongkang 2006-01-26 21:04:05 EST
I met the similar abnormal text display in text installation mode. My machine 
is Intel 915 mainboard. 

1. I also met anaconda report exception about alocate memory. 

2. The installation page for NIC configuration (DHCP/manual assign IP) is 
alwasy missing in my text installation mode.

3. The graphic mode installation is okay.

4. The color of first page (selecting installation ways) is too odd (RED) to 
see the words. (please see the 3nd attached pic)
Comment 4 You, Yongkang 2006-01-26 21:06:21 EST
Created attachment 123762 [details]
Odd color of installation first page.
Comment 5 Jeremy Katz 2006-01-26 21:10:17 EST
X problems are due to agpgart not being in the i586 kernel which has since been
fixed.  Text mode has also been fixed
Comment 6 You, Yongkang 2006-01-26 21:18:24 EST
So the latest fixed has been go into development tree, or will be seen in the 
FC5-test3?

Note You need to log in before you can comment on or make changes to this bug.