Bug 179095 - error: azureus hangs during startup in non-C locale.
error: azureus hangs during startup in non-C locale.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-27 08:30 EST by Dominik 'Rathann' Mierzejewski
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: azureus-2.4.0.0-0.20060209cvs_1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-02 13:31:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of strace (131.47 KB, text/plain)
2006-04-12 08:36 EDT, Darien Fawkes
no flags Details

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2006-01-27 08:30:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
% /usr/bin/azureus
/usr/bin/build-classpath: error: could not find junit Java extension for this JVM
/usr/bin/build-classpath: error: All specified jars were not found
DEBUG::Fri Jan 27 14:31:35 GMT+01:00 2006
  java.lang.IllegalStateException: keyring not loaded
   at gnu.crypto.jce.keyring.GnuKeyring.<clinit> (gnu-crypto-2.0.1.jar.so)
   at java.lang.Class.initializeClass (libgcj.so.7)
   at java.lang.reflect.Constructor.newInstance (libgcj.so.7)
   at gnu.java.security.Engine.getInstance (libgcj.so.7)
   at gnu.java.security.Engine.getInstance (libgcj.so.7)
   at java.security.KeyStore.getInstance (libgcj.so.7)
   at java.security.KeyStore.getInstance (libgcj.so.7)
   at org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl.ensureStoreExists (Azureus2.jar.so)
   at org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl.initialise (Azureus2.jar.so)
   at org.gudy.azureus2.core3.security.SESecurityManager.initialise (Azureus2.jar.so)
   at org.gudy.azureus2.core3.config.impl.ConfigurationChecker.setSystemProperties (Azureus2.jar.so)
   at org.gudy.azureus2.core3.config.impl.ConfigurationManager.initialise (Azureus2.jar.so)
   at org.gudy.azureus2.core3.config.impl.ConfigurationManager.getInstance (Azureus2.jar.so)
   at org.gudy.azureus2.core3.config.COConfigurationManager.initialise (Azureus2.jar.so)
   at com.aelitis.azureus.core.impl.AzureusCoreImpl.<init> (Azureus2.jar.so)
   at com.aelitis.azureus.core.impl.AzureusCoreImpl.create (Azureus2.jar.so)
   at com.aelitis.azureus.core.AzureusCoreFactory.create (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.<init> (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.main (Azureus2.jar.so)

DEBUG::Fri Jan 27 14:31:35 GMT+01:00 2006
  java.lang.IllegalStateException: keyring not loaded
   at gnu.crypto.jce.keyring.GnuKeyring.<clinit> (gnu-crypto-2.0.1.jar.so)
   at java.lang.Class.initializeClass (libgcj.so.7)
   at java.lang.reflect.Constructor.newInstance (libgcj.so.7)
   at gnu.java.security.Engine.getInstance (libgcj.so.7)
   at gnu.java.security.Engine.getInstance (libgcj.so.7)
   at java.security.KeyStore.getInstance (libgcj.so.7)
   at java.security.KeyStore.getInstance (libgcj.so.7)
   at org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl.ensureStoreExists (Azureus2.jar.so)
   at org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl.initialise (Azureus2.jar.so)
   at org.gudy.azureus2.core3.security.SESecurityManager.initialise (Azureus2.jar.so)
   at org.gudy.azureus2.core3.config.impl.ConfigurationChecker.setSystemProperties (Azureus2.jar.so)
   at org.gudy.azureus2.core3.config.impl.ConfigurationManager.initialise (Azureus2.jar.so)
   at org.gudy.azureus2.core3.config.impl.ConfigurationManager.getInstance (Azureus2.jar.so)
   at org.gudy.azureus2.core3.config.COConfigurationManager.initialise (Azureus2.jar.so)
   at com.aelitis.azureus.core.impl.AzureusCoreImpl.<init> (Azureus2.jar.so)
   at com.aelitis.azureus.core.impl.AzureusCoreImpl.create (Azureus2.jar.so)
   at com.aelitis.azureus.core.AzureusCoreFactory.create (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.<init> (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.main (Azureus2.jar.so)

DEBUG::Fri Jan 27 14:31:36 GMT+01:00 2006
  java.lang.NullPointerException
   at org.gudy.azureus2.core3.internat.MessageText$4.accept (Azureus2.jar.so)
   at java.io.File.performList (libgcj.so.7)
   at java.io.File.list (libgcj.so.7)
   at org.gudy.azureus2.core3.internat.MessageText.getLocales (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.StartupUtils.setLocale (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.Initializer.run (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread$1.runSupport (Azureus2.jar.so)
   at org.gudy.azureus2.core3.util.AERunnable.run (Azureus2.jar.so)
   at java.lang.Thread.run (libgcj.so.7)

and just hangs there on the splash screen. The above happens on the first run.
Subsequent runs produce only the followin:
% /usr/bin/azureus
/usr/bin/build-classpath: error: could not find junit Java extension for this JVM
/usr/bin/build-classpath: error: All specified jars were not found
DEBUG::Fri Jan 27 14:34:21 GMT+01:00 2006
  java.lang.NullPointerException
   at org.gudy.azureus2.core3.internat.MessageText$4.accept (Azureus2.jar.so)
   at java.io.File.performList (libgcj.so.7)
   at java.io.File.list (libgcj.so.7)
   at org.gudy.azureus2.core3.internat.MessageText.getLocales (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.StartupUtils.setLocale (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.Initializer.run (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.SWTThread$1.runSupport (Azureus2.jar.so)
   at org.gudy.azureus2.core3.util.AERunnable.run (Azureus2.jar.so)
   at java.lang.Thread.run (libgcj.so.7)

% rpm -q azureus libgcj java-1.4.2-gcj-compat libswt3-gtk2 libgtk-java glib-java gnu-crypto jakarta-commons-cli
azureus-2.3.0.6-19.fc5.i386
libgcj-4.1.0-0.16.i386
java-1.4.2-gcj-compat-1.4.2.0-40jpp_63rh.i386
libswt3-gtk2-3.1.1-1jpp_16fc.i386
libgtk-java-2.8.2-0.i386
glib-java-0.2.2-1.i386
gnu-crypto-2.0.1-1jpp_11fc.i386
jakarta-commons-cli-1.0-6jpp_5.fc5.i386


Version-Release number of selected component (if applicable):
azureus-2.3.0.6-19.fc5

How reproducible:
Always

Steps to Reproduce:
1. /usr/bin/azureus
  

Additional info:
Comment 1 Anthony Green 2006-01-27 08:42:12 EST
Thanks!  There are 3 problems happening here.  Only 1 seems critical, and I'm
going to adjust the bug summary accordingly.

(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103
Fedora/1.5-4 Firefox/1.5
> 
> Description of problem:
> % /usr/bin/azureus
> /usr/bin/build-classpath: error: could not find junit Java extension for this JVM
> /usr/bin/build-classpath: error: All specified jars were not found

This was a stupid omission on my part.  The error is ignorable.  I'll fix this
by removing the reference to junit in the startup script.

> DEBUG::Fri Jan 27 14:31:35 GMT+01:00 2006
>   java.lang.IllegalStateException: keyring not loaded

This is something that we need to put on the back-burner.  Azureus still mostly
runs fine without a keyring.


> DEBUG::Fri Jan 27 14:31:36 GMT+01:00 2006
>   java.lang.NullPointerException
>    at org.gudy.azureus2.core3.internat.MessageText$4.accept (Azureus2.jar.so)

This is the one that is immediately troubling.  What locale are you running in?


Comment 2 Dominik 'Rathann' Mierzejewski 2006-01-27 08:52:28 EST
% locale
LANG=en_GB.UTF-8
LC_CTYPE=pl_PL.UTF-8
LC_NUMERIC=en_GB.UTF-8
LC_TIME=en_GB.UTF-8
LC_COLLATE=pl_PL.UTF-8
LC_MONETARY=pl_PL.UTF-8
LC_MESSAGES=en_GB.UTF-8
LC_PAPER=pl_PL.UTF-8
LC_NAME=pl_PL.UTF-8
LC_ADDRESS=pl_PL.UTF-8
LC_TELEPHONE=pl_PL.UTF-8
LC_MEASUREMENT=pl_PL.UTF-8
LC_IDENTIFICATION=pl_PL.UTF-8
LC_ALL=

Note that binary azureus build from sourceforge and sun's java 1.5.0.06 work fine.
Comment 3 Anthony Green 2006-01-28 12:45:17 EST
My theory about the locale appears to be wrong, since I can run in any locale.

Just out of curiosity, can you try kernel 2.6.15-1.1826.2.10_FC5?  I believe
that this is the kernel that shipped with FC5t2.  We've seen apps freeze on
newer kernels, but on x86-64 only so far.  See Bug 179228.
Comment 4 Dominik 'Rathann' Mierzejewski 2006-01-30 07:41:30 EST
No change with
% uname -r
2.6.15-1.1826.2.10_FC5
Comment 5 Anthony Green 2006-03-09 19:52:21 EST
Are you still having problems?  People are reporting nothing but success now.

Thanks,

AG
Comment 6 Dominik 'Rathann' Mierzejewski 2006-03-16 07:34:27 EST
No, the problems I mentioned are gone with the 2.4.0.0 version. There are
others, maybe I'll open another bug for them.
Comment 7 Darien Fawkes 2006-04-11 10:33:45 EDT
(In reply to comment #5)
> Are you still having problems?  People are reporting nothing but success now.

I have a similar problem in that, when I run azureus from the command line, I
get the following error before the program exits:

/usr/bin/build-classpath: error: Could not find swt-gtk-3.1.1 Java extension for
this JVM
/usr/bin/build-classpath: error: Some specified jars were not found
Exception in thread "main" java.lang.NoClassDefFoundError:
org.gudy.azureus2.ui.swt.StartServer
   at java.lang.Class.initializeClass (libgcj.so.7)
   at org.gudy.azureus2.ui.swt.Main.<init> (Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.main (Azureus2.jar.so)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Display not
found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/share/java/jakarta-commons-cli.jar,file:/usr/share/java/log4j.jar,file:/usr/share/java/gtk2.8.jar,file:/usr/share/java/glib0.2.jar,file:/usr/share/azureus/Azureus2.jar],
parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.net.URLClassLoader.findClass (libgcj.so.7)
   at java.lang.ClassLoader.loadClass (libgcj.so.7)
   at java.lang.ClassLoader.loadClass (libgcj.so.7)
   at java.lang.Class.initializeClass (libgcj.so.7)
   ...2 more

Version-Release number of selected component:
azureus-2.4.0.3.fc5

Also, for me the binary azureus build from Sourceforge and Sun's java 1.5.0.06
work fine.

Any ideas?
Comment 8 Anthony Green 2006-04-11 10:51:49 EDT
(In reply to comment #7)
> I have a similar problem in that, when I run azureus from the command line, I
> get the following error before the program exits:
> 
> /usr/bin/build-classpath: error: Could not find swt-gtk-3.1.1 Java extension for
> this JVM

Please run and report the results of "which java && java -version && which javac
&& javac -version" (as per the release notes).

I suspect that you're running Sun java and an azureus older than 
azureus-2.4.0.3-0.20060328cvs_3.fc5.  If so, either upgrading azureus or running
with the java-1.4.2-gcj-compat alternative should fix the problem.

AG

Comment 9 Darien Fawkes 2006-04-11 11:05:43 EDT
Thanks for the quick response.

Here is the result:

$ which java && java -version && which javac && javac -version
/usr/bin/java
java version "1.4.2"
gij (GNU libgcj) version 4.1.0 20060304 (Red Hat 4.1.0-3)

Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
/usr/bin/which: no javac in
(/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/darien/bin)

Also, I am using azureus-2.4.0.3-0.20060328cvs_4.fc5
Comment 10 Anthony Green 2006-04-11 11:36:09 EDT
(In reply to comment #9)
> Also, I am using azureus-2.4.0.3-0.20060328cvs_4.fc5

Please attach the results of the following command to this bug...

$ strace -f -eopen -efile azureus


Comment 11 Darien Fawkes 2006-04-12 08:36:33 EDT
Created attachment 127655 [details]
Output of strace
Comment 12 Darien Fawkes 2006-04-12 09:54:31 EDT
I have attached the results above.

FD

Note You need to log in before you can comment on or make changes to this bug.