This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 179105 - ekiga doesn't start unless allow_execstack is set to 1
ekiga doesn't start unless allow_execstack is set to 1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-27 09:43 EST by Jeff Needle
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-28 17:15:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Needle 2006-01-27 09:43:05 EST
Description of problem:

ekiga is a relatively new package in Fedora.  It won't start without setting
allow_execstack.

$ ekiga
ekiga: error while loading shared libraries: libSDL-1.2.so.0: cannot enable
executable stack as shared object requires: Permission denied

Version-Release number of selected component (if applicable):

ekiga-1.99.0-1, SDL-1.2.9-3, selinux-policy-targeted-2.2.5-1

How reproducible:

Always

Steps to Reproduce:
1. ekiga
  
Actual results:

$ ekiga
ekiga: error while loading shared libraries: libSDL-1.2.so.0: cannot enable
executable stack as shared object requires: Permission denied

Expected results:

$ ekiga
X11 connection rejected because of wrong authentication.
The application 'ekiga' lost its connection to the display localhost:10.0;
most likely the X server was shut down or you killed/destroyed
the application.

;-)

Additional info:

Works after setsebool allow_execstack 1
Comment 1 Daniel Walsh 2006-01-28 16:28:28 EST
Why does ekiga need allow_execstack.  This is probably a bad thing.

http://people.redhat.com/drepper/selinux-mem.html
Comment 2 Daniel Walsh 2006-01-28 17:15:01 EST
Seems to be fixed in todays rawhide.  

Note You need to log in before you can comment on or make changes to this bug.