Bug 179110 - up2date fails to update xerces
Summary: up2date fails to update xerces
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Beth Nackashi
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 168424 169775
TreeView+ depends on / blocked
 
Reported: 2006-01-27 15:04 UTC by Beth Nackashi
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2006-0105
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 15:39:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0105 qe-ready SHIPPED_LIVE up2date bug fix update 2006-03-14 05:00:00 UTC

Description Beth Nackashi 2006-01-27 15:04:37 UTC
Description of problem:
up2date fails to update xerces package

Version-Release number of selected component (if applicable):
up2date-4.4.63-3

How reproducible:
always

Steps to Reproduce:
1.  ks a client to rhel 3 u6 with @ Everything
2.  install the latest up2date
3.  subscribe the client to all available channels on hosted
4.  run 'up2date'
5.  check 'xerces' package to update
6.  click 'Forward'
  
Actual results:
/var/log/up2date logs a traceback (shown below) and up2date advances to the next
panel ('Available Package Installs').  You can't scroll in this panel for some
reason.  If you click 'Forward' it hangs on the Progress Dialog.  For days and
days, literally.


Expected results:


Additional info:
from the log file:

[Wed Jan 25 16:06:11 2006] up2date updating login info
[Wed Jan 25 16:06:11 2006] up2date logging into up2date server
[Wed Jan 25 16:06:11 2006] up2date successfully retrieved authentication token
from up2date server
[Wed Jan 25 16:06:16 2006] up2date availablePackageList from network
[Wed Jan 25 16:06:16 2006] up2date Unable to import repomd support so repomd
support will not be available
[Wed Jan 25 16:06:37 2006] up2date solving dep for:
['lib-javax-xml-parsers-2.2.1.so', 'lib-org-w3c-dom-2.2.1.so',
'lib-org-xml-sax-2.2.1.so', 'lib-javax-xml-parsers-2.2.1.so',
'lib-org-w3c-dom-2.2.1.so', 'lib-org-xml-sax-2.2.1.so',
'lib-javax-xml-parsers-2.2.1.so', 'lib-org-w3c-dom-2.2.1.so',
'lib-org-xml-sax-2.2.1.so', 'lib-javax-xml-parsers-2.2.1.so',
'lib-org-w3c-dom-2.2.1.so', 'lib-javax-xml-parsers-2.2.1.so',
'lib-org-apache-xerces-2.2.1.so', 'lib-org-w3c-dom-2.2.1.so',
'lib-org-xml-sax-2.2.1.so', 'xml-commons-apis', 'xml-commons-resolver']
[Wed Jan 25 16:06:40 2006] up2date solving dep for:
['lib-javax-xml-parsers-2.2.1.so', 'lib-org-w3c-dom-2.2.1.so',
'lib-org-xml-sax-2.2.1.so', 'lib-javax-xml-parsers-2.2.1.so',
'lib-org-w3c-dom-2.2.1.so', 'lib-org-xml-sax-2.2.1.so',
'lib-javax-xml-parsers-2.2.1.so', 'lib-org-w3c-dom-2.2.1.so',
'lib-org-xml-sax-2.2.1.so', 'lib-javax-xml-parsers-2.2.1.so',
'lib-org-w3c-dom-2.2.1.so', 'lib-javax-xml-parsers-2.2.1.so',
'lib-org-apache-xerces-2.2.1.so', 'lib-org-w3c-dom-2.2.1.so',
'lib-org-xml-sax-2.2.1.so', 'xml-commons']
[Wed Jan 25 16:06:43 2006] up2date solving dep for:
['lib-javax-xml-parsers-2.2.1.so', 'lib-org-w3c-dom-2.2.1.so',
'lib-org-xml-sax-2.2.1.so', 'lib-javax-xml-parsers-2.2.1.so',
'lib-org-w3c-dom-2.2.1.so', 'lib-org-xml-sax-2.2.1.so',
'lib-javax-xml-parsers-2.2.1.so', 'lib-org-w3c-dom-2.2.1.so',
'lib-org-xml-sax-2.2.1.so', 'lib-javax-xml-parsers-2.2.1.so',
'lib-org-w3c-dom-2.2.1.so', 'lib-javax-xml-parsers-2.2.1.so',
'lib-org-apache-xerces-2.2.1.so', 'lib-org-w3c-dom-2.2.1.so',
'lib-org-xml-sax-2.2.1.so']
An error has occurred:
exceptions.TypeError
See /var/log/up2date for more information
[Wed Jan 25 16:06:46 2006] up2date   File
"/usr/share/rhn/up2date_client/gui.py", line 1490, in onPackagePageNext
    ret = self.__packagePageDryRun()
   File "/usr/share/rhn/up2date_client/gui.py", line 1418, in __packagePageDryRun
    self.__refreshCallback)
   File "/usr/share/rhn/up2date_client/up2date.py", line 384, in dryRun
    ret = depsolve.solvedep()
   File "/usr/share/rhn/up2date_client/depSolver.py", line 750, in solvedep
    ret = self.process_deps(deps)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 644, in process_deps
    changed = self.__dependencies(dependencies)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 410, in __dependencies
    solved, skiplist = self.__skip(solved)
   File "/usr/share/rhn/up2date_client/depSolver.py", line 208, in __skip
    xlist = packageList.removeSkipPackagesFromList(plist)
   File "/usr/share/rhn/up2date_client/packageList.py", line 793, in
removeSkipPackagesFromList
    if fnmatch.fnmatch(pkgList[index][0], pattern):
   File "/usr/lib/python2.2/fnmatch.py", line 38, in fnmatch
    return fnmatchcase(name, pat)
   File "/usr/lib/python2.2/fnmatch.py", line 70, in fnmatchcase
    return _cache[pat].match(name) is not None

Comment 1 Adrian Likins 2006-01-27 18:17:43 UTC
can you attach the /etc/sysconfig/rhn/up2date? (well, if you've modified
skipPackageList that is, if it's "stock" let me know). Something weird is
going when it's trying to compute if the package name is on the skip list.

Also, since this is pretty deep in the errata QA process, any new bugs really
need to get mentioned in the errata QA request as well, so more folks can see it
and decide if it's a rhel blocker/etc. Just popping it on the rhnupr3u7 isn't
going to get it on my radar. 

Comment 2 Beth Nackashi 2006-01-27 19:22:49 UTC
/etc/sysconfig/rhn/up2date skipPackageList was not modified

Comment 3 Adrian Likins 2006-01-27 20:26:18 UTC
something weird in the depsolver, looks like as part of the fix for #149472

Not sure what the right fix is atm, investigating.


Comment 4 Adrian Likins 2006-01-27 21:53:24 UTC
fix is in up2date-4.4.66-3

Comment 5 Beth Nackashi 2006-01-28 00:21:24 UTC
verified with up2date-4.4.67-3 on i386, ia64, and x86_64

Comment 6 Red Hat Bugzilla 2006-03-15 15:39:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0105.html



Note You need to log in before you can comment on or make changes to this bug.