Bug 179128 - Bugzilla cannot locate local .pm files
Bugzilla cannot locate local .pm files
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-27 11:12 EST by Danny
Modified: 2013-06-23 22:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 15:29:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Danny 2006-01-27 11:12:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 
Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
This is a problem with this package because when I install the regular version 
everything is ok. I am running perl 5.8.5 and mysql 4 on apache 2.0 on a Red 
Hat Enterprise 4 AS box. 

Software error:

Can't locate Bugzilla/Util.pm in @INC (@INC 
contains: . /usr/lib/perl5/5.8.5/i386-linux-thread-
multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/per
l5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1
 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_p
erl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-
thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-
multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-
multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-
multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-
multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib
/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_
perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl) at 
CGI.pl line 35.
BEGIN failed--compilation aborted at CGI.pl line 35.

For help, please send mail to the webmaster (root@localhost), giving this error 
message and the time and date of the error.
Software error:

[Wed Jan 18 12:55:06 2006] index.cgi: Can't locate Bugzilla/Util.pm in @INC 
(@INC contains: . /usr/lib/perl5/5.8.5/i386-linux-thread-
multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-
multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/per
l5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1
 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_p
erl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-
thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-
multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-
multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-
multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-
multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib
/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_
perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl) at 
CGI.pl line 35.
[Wed Jan 18 12:55:06 2006] index.cgi: BEGIN failed--compilation aborted at 
CGI.pl line 35.
Compilation failed in require at /bugzilla/index.cgi line 37.

I have tried making a PERL5LIB variable putting the files in one of the @INC 
directory and no go. Before this the .htaccess prevents all users from 
accessing  the server files.

Version-Release number of selected component (if applicable):
2.18

How reproducible:
Always

Steps to Reproduce:
1. Run ./checksetup.pl and go through the whole installation
2. if server says forbidden delete the .htaccess file.
3. If get error about permission fix those. Go to the index.cgi page and get 
the error above

  
Actual results:


Expected results:


Additional info:
Comment 1 David Lawrence 2006-01-27 11:26:58 EST
Where did you get the version of Bugzilla that you are trying to install? If it
is the one available from our version of Bugzilla's home page, there is no
support provided and isn't even guaranteed to work with MySQL at all since it is
heavily altered to work with PostgreSQL. If you are looking for a supported
version of Bugzilla, please download from http://www.bugzilla.org. The new
versions are much better than ours anyway.

Note You need to log in before you can comment on or make changes to this bug.