Bug 179195 - up2date window size larger than screen resolution
up2date window size larger than screen resolution
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-27 18:45 EST by Beth Nackashi
Modified: 2013-02-26 19:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 05:37:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of bn_IN firstboot page (125.60 KB, image/png)
2006-01-31 04:41 EST, Runa Bhattacharjee
no flags Details
Screenshot of bn_IN firstboot, Test Sound page (111.33 KB, image/png)
2006-01-31 04:43 EST, Runa Bhattacharjee
no flags Details

  None (edit)
Comment 1 Beth Nackashi 2006-01-27 18:47:18 EST
Also need to make sure the following languages translate properly (supported in
rhel 4 only):

Russian (ru)
Bengali (bn_IN)
Gujarati (gu_IN)
Hindi (hi_IN)
Punjabi (pa_IN)
Tamil (ta_IN) 
Comment 2 Lawrence Lim 2006-01-29 21:22:53 EST
Could the respective Language Maintainer from Localisation Team please verify
that the translation strings fit into 800x600 resolution in this bug? Thanks.

Russian (ru)
Bengali (bn_IN)
Gujarati (gu_IN)
Hindi (hi_IN)
Punjabi (pa_IN)
Tamil (ta_IN) 



Comment 3 Runa Bhattacharjee 2006-01-31 04:41:26 EST
Created attachment 123900 [details]
Screenshot of bn_IN firstboot page

The top and bottom part of the window is beyond the screen. Hiding the
"Previous" and "Next" buttons.
Comment 4 Runa Bhattacharjee 2006-01-31 04:43:17 EST
Created attachment 123901 [details]
Screenshot of bn_IN firstboot, Test Sound page

The button widget for "Play Test Sound" is being cut off on the right side
although the text is much shorter.
Comment 5 Runa Bhattacharjee 2006-01-31 04:47:11 EST
Tested for bn_IN.

The translated text fits into the widgets in the 800X600 resolution screen.
Unfortunately, the window is too big for the actual screen, hence hiding the top
and bottom part including the "Previous" and "Next" button.[firstboot.png]

Additionally, the Play Test Sound button on the soundcard detection page is
being cut off on the right side, inspite of the text being much shorter.
[firstboot-3.png]
Comment 6 Ankit Patel 2006-01-31 05:32:46 EST
Test results for Gujarati (gu_IN):-
===================================
The translated text fits into the widgets in the 800X600 resolution screen.
Unfortunately, the window is too big for the actual screen, hence hiding the top
and bottom part including the "Previous" and "Next" button. Rest is fine.
Comment 7 Rajesh Ranjan 2006-01-31 05:41:03 EST
Tested for Hindi (hi_IN). The translated text fits into the widgets in the
800X600 resolution screen.But window is big for the actual screen, do it hides
the top
and bottom part including the "Previous" and "Next" button. 

Comment 8 Runa Bhattacharjee 2006-01-31 05:41:56 EST
bn_IN correction:

The Play Test Sound Button is being extended due to the translated text for the
label "Vendor". Modified and Shortened in the latest version of
System-config-soundcard/ bn_IN.po
Comment 9 Beth Nackashi 2006-02-01 16:50:32 EST
using up2date-4.4.67-4 on i386, ia64, and x86_64:

English (en) -- FIXED
French (fr) -- FIXED
German (de) -- FIXED
Italian (it) -- FIXED
Spanish (es) -- NOT FIXED
Brazilian Portuguese (pt_BR) -- FIXED
Japanese (ja) -- FIXED
Simplified Chinese (zh_CN) -- NOT FIXED
Traditional Chinese (zh_TW) -- NOT FIXED
Korean (ko) -- NOT FIXED
Russian (ru) -- NOT FIXED
Bengali (bn_IN) -- NOT FIXED
Gujarati (gu_IN) -- FIXED
Hindi (hi_IN) -- NOT FIXED
Punjabi (pa_IN) -- FIXED
Tamil (ta_IN) -- NOT FIXED


By "FIXED" I mean the entire up2date window (not just the translated text) is
contained within the 800x600 screen without having to move or resize the window.

By "NOT FIXED" I mean there are parts (however large or small) of the up2date
window that are beyond the viewable 800x600 screen; the up2date window must be
moved or manually resized to fit in the screen.
Comment 10 Chester Cheng 2006-12-01 01:05:45 EST
Hi,

Is this bug still valid?

(doc-i18n-list removed from cc list.  ankit and ccheng added.)
Comment 11 Red Hat Bugzilla 2007-04-11 20:28:28 EDT
User bnackash@redhat.com's account has been closed
Comment 12 Caius Chance 2008-06-17 02:43:07 EDT
Has all supported lang been confirmed fitting within 800x600 windows?
Comment 15 Caius Chance 2009-02-16 12:27:33 EST
ping

Note You need to log in before you can comment on or make changes to this bug.