This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 179200 - ImageMagick-devel should "Requires" lcms-devel
ImageMagick-devel should "Requires" lcms-devel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-27 19:20 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 09:03:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mock build.log with compile failure (50.13 KB, text/plain)
2006-01-27 19:20 EST, Kevin Fenzi
no flags Details

  None (edit)
Description Kevin Fenzi 2006-01-27 19:20:09 EST
Description of problem:
autotrace fails to build under mock for fc5/devel. 
Possibly a missing BuildRequires for lcms-devel.

end of mock build.log: 

gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m32 -march=i386 -mtune=pentium4
-fasynchronous-unwind-tables -o .libs/autotrace atou.o main.o getopt.o getopt1.o
 ./.libs/libautotrace.so -L/usr/lib -lMagick -llcms -ltiff
/usr/lib/libfreetype.so -ljpeg -lgs -lXext -lSM -lICE -lX11 -lXt -lbz2 -lpthread
-lpng -lz -lm
/usr/bin/ld: cannot find -llcms
collect2: ld returned 1 exit status
make[1]: *** [autotrace] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/autotrace-0.31.1'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.78515 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.78515 (%build)

Full build.log attached as well.
Comment 1 Kevin Fenzi 2006-01-27 19:20:09 EST
Created attachment 123816 [details]
mock build.log with compile failure
Comment 2 Roozbeh Pournader 2006-01-28 15:54:30 EST
This is actually a bug in ImageMagick-devel. It should have a dependency on
lcms-devel, since Magick-config reports "-llcms" but does not have it as a
dependency.
Comment 3 Roozbeh Pournader 2006-01-29 05:10:56 EST
For the record, this happens with ImageMagick-devel-6.2.5.4-3.
Comment 4 Matthias Clasen 2006-01-30 09:03:24 EST
Will be fixed with the next rebuild.

Note You need to log in before you can comment on or make changes to this bug.