Bug 17921 - an excessive bitshift
Summary: an excessive bitshift
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mpg123   
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-29 23:50 UTC by Michal Jaegermann
Modified: 2014-03-17 02:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-29 23:52:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
64-bit Alpha fixes to mpg123 (3.93 KB, application/octet-stream)
2000-09-29 23:52 UTC, Michal Jaegermann
no flags Details

Description Michal Jaegermann 2000-09-29 23:50:42 UTC
Past experience indicates that a comment
/* 24 is enough because tab13 has max. a 19 bit huffvector */
in mpg123 is telling a truth and you do not really want 56-bit shifts.
At least attached patch is needed although an explicit use of a type
with a guaranteed witdh, like u32, would be even better.
Also Makefile has to be modified.

I cannot test it right now with new libraries but most likely other
attached changes will be also beneficial.  The patch mentioned above
is in the last section.

  Michal
  michal@harddata.com

Comment 1 Michal Jaegermann 2000-09-29 23:52:38 UTC
Created attachment 3573 [details]
64-bit Alpha fixes to mpg123

Comment 2 Bill Nottingham 2000-10-17 04:49:29 UTC
will be fixed in mpg123-0.59r-9.


Note You need to log in before you can comment on or make changes to this bug.