Bug 179225 - Default yum update fails immediately post installation with dependency errors
Default yum update fails immediately post installation with dependency errors
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 179275 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-28 11:11 EST by Tim Hedger-Gourlay
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-28 12:46:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Hedger-Gourlay 2006-01-28 11:11:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
I've installed FC5 test2 on my AMD64 machine and tried to get all packages up to date with yum update.  However, this fails with a dependency error suggesting that the set of repositories yum is configured to use by the installation is not self-consistent.

yum update starts perfectly normally and identifies a long list of packages to updated, but it then fails with dependency errors relating to libedataserver.  Output of the command from the dependency check is shown below.




Version-Release number of selected component (if applicable):
yum-2.5.1-1

How reproducible:
Always

Steps to Reproduce:
1. su -
2. <password>
3. yum update
  

Actual Results:  --> Running transaction check
--> Processing Dependency: xpdf-utils for package: xpdf
--> Processing Dependency: firstboot-tui for package: firstboot
--> Processing Dependency: wpa_supplicant for package: NetworkManager
--> Processing Dependency: /usr/bin/msgfmt for package: redhat-lsb
--> Processing Dependency: libedataserver-1.2.so.6()(64bit) for package: ekiga
--> Processing Dependency: libgdiplus for package: mono-core
--> Processing Dependency: poppler-utils for package: beagle
--> Processing Dependency: libnl.so.1()(64bit) for package: NetworkManager
--> Processing Dependency: liblcms.so.1 for package: ImageMagick
--> Processing Dependency: /usr/bin/gettext for package: redhat-lsb
--> Processing Dependency: gstreamer-tools >= 0.10.2 for package: gstreamer
--> Processing Dependency: libedataserver-1.2.so.6()(64bit) for package: nautilus-sendto
--> Processing Dependency: libedataserver-1.2.so.6()(64bit) for package: evolution-sharp
--> Processing Dependency: libgpod for package: rhythmbox
--> Processing Dependency: libgpod.so.0()(64bit) for package: rhythmbox
--> Processing Dependency: poppler-utils >= 0.5.0-4 for package: xpdf
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gettext.x86_64 0:0.14.5-2.2 set to be updated
---> Package libgdiplus.x86_64 0:1.1.13-1 set to be updated
---> Package libnl.x86_64 0:1.0-0.7.pre5 set to be updated
---> Package libgpod.x86_64 0:0.3.0-2 set to be updated
---> Package gstreamer-tools.x86_64 0:0.10.2-1 set to be updated
---> Package wpa_supplicant.x86_64 0:0.4.7-2 set to be updated
---> Package firstboot-tui.noarch 0:1.4.2-1 set to be updated
---> Package xpdf-utils.x86_64 1:3.01-11 set to be updated
---> Package lcms.i386 0:1.15-1 set to be updated
---> Package poppler-utils.x86_64 0:0.5.0-4 set to be updated
--> Running transaction check
--> Processing Dependency: libedataserver-1.2.so.6()(64bit) for package: ekiga
--> Processing Dependency: libedataserver-1.2.so.6()(64bit) for package: evolution-sharp
--> Processing Dependency: netconfig for package: firstboot-tui
--> Processing Dependency: libedataserver-1.2.so.6()(64bit) for package: nautilus-sendto
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package netconfig.x86_64 0:0.8.24-1.1 set to be updated
--> Running transaction check
--> Processing Dependency: libedataserver-1.2.so.6()(64bit) for package: ekiga
--> Processing Dependency: libedataserver-1.2.so.6()(64bit) for package: evolution-sharp
--> Processing Dependency: libedataserver-1.2.so.6()(64bit) for package: nautilus-sendto
--> Finished Dependency Resolution

Expected Results:  The set of repositories yum is configured with post install of FC should be consistent such that yum update will update any packages that need updating successfully.

Additional info:
Comment 1 Ignacio Vazquez-Abrams 2006-01-28 12:46:11 EST
(In reply to comment #0)
> Expected Results:  The set of repositories yum is configured with post install
of FC should be consistent such that yum update will update any packages that
need updating successfully.

Test releases update against Rawhide, and Rawhide is known to be inconsistent
from time to time. If you need consistency then you shouldn't be running a test
release.

Besides, this isn't even a bug in yum.
Comment 2 Ignacio Vazquez-Abrams 2006-01-29 14:38:40 EST
*** Bug 179275 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.