Bug 179227 - genhomedircon returned error code 1
genhomedircon returned error code 1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-28 11:40 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.29.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 16:05:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-01-28 11:40:21 EST
Description of problem:
Upgrading to latest targeted SELinux policy gives me the following output:

[...]
   1:selinux-policy         ########################################### [ 50%]
   2:selinux-policy-targeted########################################### [100%]
Traceback (most recent call last):
  File "/usr/sbin/genhomedircon", line 364, in ?
    selconf.write()
  File "/usr/sbin/genhomedircon", line 325, in write
    fd.write(self.genoutput())
  File "/usr/sbin/genhomedircon", line 316, in genoutput
    ret += self.genHomeDirContext()
  File "/usr/sbin/genhomedircon", line 265, in genHomeDirContext
    users = self.getUsers()
  File "/usr/sbin/genhomedircon", line 210, in getUsers
    (status, list, lsize) = semanage_seuser_list(self.semanageHandle)
NameError: global name 'semanage_seuser_list' is not defined
libsemanage.semanage_install_sandbox: genhomedircon returned error code 1.
[...]

Version-Release number of selected component (if applicable):
policycoreutils-1.29.11-3
libsemanage-1.5.18-1
selinux-policy-2.2.8-1

Actual results:
Error messages.

Expected results:
No errors ;-)
Comment 1 Daniel Walsh 2006-01-28 16:16:41 EST
Looks like one package made Rawhide and another missed the cutoff.  Fixed will
be out tonight.

policycoreutils-1.29.15-1
Comment 2 Tom London 2006-01-30 16:44:03 EST
Has this gotten pushed yet?
Comment 3 Daniel Walsh 2006-01-31 10:00:18 EST
Yes,  Should be in today's Rawhide.
Comment 4 Robert Scheck 2006-01-31 16:05:22 EST
Thank you - works.

Note You need to log in before you can comment on or make changes to this bug.