Bug 179229 - Font size error affecting Gecko browsers etc.
Font size error affecting Gecko browsers etc.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
http://silas.psfc.mit.edu/fontsizebug...
:
: 179226 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-28 12:59 EST by Ian Hutchinson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 01:03:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Hutchinson 2006-01-28 12:59:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050717

Description of problem:
A style of the form
div {
 font: 12px Arial, Helvetica, sans-serif;
 color:#666666;
 line-height:20px;
 margin-top:0px;
 }
produces rendering in fixed-tiny-size font.
The fault is in the 12px, but any ??px produces the same thing, regardless of
the face. Styles like this are widespread. The bug occurs with Mozilla builds that work fine on FC3 (fontconfig-2.2.3-5). That is why I conclude it is fontconfig, but it possibly might be some other aspect of the font/X system.

Version-Release number of selected component (if applicable):
fontconfig-2.2.3-13

How reproducible:
Always

Steps to Reproduce:
1. Use FC4 standard distribution with, e.g. firefox
2. Go to http://silas.psfc.mit.edu/fontsizebug.html
3. Enjoy! (NOT)
  

Additional info:
Comment 1 Ian Hutchinson 2006-01-28 13:02:47 EST
I have tracked this bug down. It was caused by a font helvR.9.pcf in my
directory /home/usr/share/fonts/Math which was being defaulted to when the 12px
was encountered. I don't know where that file came from. It did not seem to be
owned by rpm packages. I'd guess it just bit me because the fc-cache program was
rerun on this directory when FC4 was installed. 

I conclude that this was not a fontconfig error, but an error in my font setup
more generally. 

Sorry to be a nuisance. Thanks for all the fish
Comment 2 Matthias Clasen 2006-11-27 01:03:56 EST
*** Bug 179226 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.