Bug 179231 - kppp requires consolehelper, missing dependency
Summary: kppp requires consolehelper, missing dependency
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-28 18:12 UTC by Ville Skyttä
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 3.5.8-9.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 18:11:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2006-01-28 18:12:41 UTC
/usr/bin/kppp is a symlink to consolehelper, but the dependency is missing. 
Requires: usermode-gtk would fix it (-gtk because kppp is a GUI app).

On the other hand, it would be even better to have this fixed in a way that
wouldn't require pulling in gtk2/glib2 stuff.  Maybe using kdesu?

Comment 1 Doncho Gunchev 2007-06-09 16:33:50 UTC
I would prefer kdesu too. consolehelper-gtk is fine, but kdesu looks more 
natural in KDE environment (will require 1 line shell script, not symlink).

Comment 2 Rex Dieter 2007-11-17 22:37:10 UTC
%changelog
* Sat Nov 15 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 7:3.5.8-7
- Requires: usermode-gtk (#179231)

(someday maybe I'll take up the fight to reinstate use of kdesu...) :)

Comment 3 Kevin Kofler 2007-11-17 22:47:36 UTC
Hmmm, was using kdesu controversial too? I thought suid bits were what the Red 
Hat folks objected to for security reasons, kdesu should be safe.

Comment 4 Fedora Update System 2007-11-20 17:46:55 UTC
kdenetwork-3.5.8-9.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2007-11-20 18:11:32 UTC
kdenetwork-3.5.8-9.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.