Bug 179232 - nm-applet won't connect to WPA network
nm-applet won't connect to WPA network
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-28 13:23 EST by Tom London
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: NetworkManager-0.7.0-0.cvs20060529.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 05:35:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ogg file of the error. (1.48 MB, application/ogg)
2006-08-24 02:04 EDT, Wade Mealing
no flags Details

  None (edit)
Description Tom London 2006-01-28 13:23:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
After installing the new NetworkManager, when I try to connect to a WPA network, I get the following:

** (nm-applet:3245): CRITICAL **: wsm_get_widget_for_active: assertion `opt != NULL' failed

** (nm-applet:3245): CRITICAL **: wsm_validate_active: assertion `opt != NULL' failed

The popup it titled "Wireless Network Key Required": "Passphrase Required by Wireless Network", but the 'Wireless Security' pull down doesn't let me enter or select anything.


Version-Release number of selected component (if applicable):
NetworkManager-0.5.1-6.cvs20060127

How reproducible:
Always

Steps to Reproduce:
1. click on tray icon, select WPA network
2.
3.
  

Additional info:
Comment 1 Tom London 2006-01-28 13:32:20 EST
Ack... looks like wpa_supplicant isn't started/running:

wpa_supplicant failed. The error was: Starting wpa_supplicant:
ioctl[SIOCSIWPMKSA]: No such device
ioctl[SIOCSIWMODE]: No such device
ioctl[SIOCGIFFLAGS]: No such device
ioctl[SIOCGIWRANGE]: No such device
ioctl[SIOCGIFINDEX]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
Failed to disable WPA in the driver.
ioctl[SIOCSIWAP]: No such device
ioctl[SIOCGIFFLAGS]: No such device
Could not configure driver to use managed mode
Could not set interface 'wlan0' UP
[FAILED]
Comment 2 Tom London 2006-01-31 10:28:56 EST
Wow..... This now works (with kernel-2.6.15-1.1884_FC5)!!!!!

Appears to be a few SELinux issues that I've filed in fedora-selinux-list, but
it works in permissive mode.

Thanks!  This is a big win.... :-D

I'm closing this.....
Comment 3 Wade Mealing 2006-08-24 01:56:22 EDT
Not workign for me. 

See istanbul attached file for example.

It may not be immediately clear, although in the screencast, these messages
appear in the logs.

Aug 24 15:36:44 localhost NetworkManager: <information> SUP: sending command
'INTERFACE_ADD ath0                wext    /var/run/wpa_supplicant '
Aug 24 15:36:44 localhost NetworkManager: <information> SUP: response was 'FAIL' 
Aug 24 15:36:44 localhost NetworkManager: <WARNING>     
nm_utils_supplicant_request_with_check (): supplicant_interface_init: supplicant
error for 'INTERFACE_ADD ath0         wext    /var/run/wpa_supplicant '. 
Response: 'FAIL'
Aug 24 15:36:44 localhost NetworkManager: <WARNING>      real_act_stage2_config
(): Activation (ath0/wireless): couldn't connect to the supplicant.

I know this is using the madwifi drivers, but this did work a few weeks back.
Comment 4 Wade Mealing 2006-08-24 02:04:38 EDT
Created attachment 134780 [details]
Ogg file of the error.

[wmealing@localhost ~]$ rpm -q NetworkManager
NetworkManager-0.7.0-0.cvs20060529.6
[wmealing@localhost ~]$ rpm -q wpa_supplicant
wpa_supplicant-0.4.8-10.1.fc6
[wmealing@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.17-1.2583.fc6 #1 SMP Tue Aug 22 00:29:50 EDT
2006 i686 i686 i386 GNU/Linux
Comment 5 Wade Mealing 2006-08-24 02:12:17 EDT
This happens on wpa , and wep networks, I first found this out on my wpa network
at home.
Comment 6 Wade Mealing 2006-08-31 05:35:16 EDT
Fixed in:
NetworkManager-0.7.0-0.cvs20060529.7

Guess it can be closed .. again

Note You need to log in before you can comment on or make changes to this bug.