Bug 179249 - Access Control Enabled by default in FC4
Access Control Enabled by default in FC4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 00:17 EST by linux01
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 09:59:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description linux01 2006-01-29 00:17:51 EST
I have set up a service in Fedora Core to allow me to graphically log in via VNC
(as per the directions in section 4 of
http://www.mythic-beasts.com/~hobb/main/index.php?pagename=VncOnLinux). Under
FC3 this worked fine, but in FC4 it seems that (X-Windows) access control is on
by default when I log in, so I cannot access many tools from the menu (such as
DNS configuration). When I try to run them from a shell some work, some don't,
but they all report X-Windows errors. If I enter "xhost +" then everything works
fine again. I can also enter "xhost +localhost" to fix the problem.

Is this expected in FC4 (and not FC3)? Is there a way to disable access control
on startup (or add localhost to the access control list)?
Comment 1 Mike A. Harris 2006-01-31 09:59:20 EST
Bugzilla is not a technical support forum.  Please post your questions
to one of the Fedora or X.Org mailing lists, and someone may be able to
provide assistance.

Just to be clear, this is not a bug.

Setting status to "NOTABUG".

Note You need to log in before you can comment on or make changes to this bug.