Bug 179274 - guile causes gnucash to crash on start
guile causes gnucash to crash on start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: guile (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
: 180313 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 11:21 EST by John Courie II
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 09:53:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Courie II 2006-01-29 11:21:06 EST
Description of problem: gnucash fails on startup with an error message that: 


[john@rallypointgamma ~]$ gnucash
/usr/bin/guile: error while loading shared libraries: libqthreads.so.12: cannot
enable executable stack as shared object requires: Permission denied

Version-Release number of selected component (if applicable):

guile-1.6.7-4.1
kernel-2.6.15-1.1872_FC5
kernel-2.6.15-1.1878_FC5
gnucash-1.8.12-2



How reproducible: always 


Steps to Reproduce:
1.  run gnucash from the terminal.
2.  read the error message regarding /usr/bin/guile
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miroslav Lichvar 2006-02-03 10:00:29 EST
Unfortunately it is impossible for guile to link against the qthreads library
due to a selinux policy issue. The library is marked correctly as requiring
executable stack.
Comment 2 Daniel Walsh 2006-02-03 10:11:48 EST
The library needs executable stack or is built with executable stack?

Does execstack -c LIBRARY fix the problem?
Comment 3 Miroslav Lichvar 2006-02-06 09:53:19 EST
Yes, execstack -c fixes it, thanks for the hint. There is an assembly source
without the GNU-stack section, so I passed --noexecstack option to the assembler.
Comment 4 Miroslav Lichvar 2006-02-07 11:41:52 EST
*** Bug 180313 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.