Bug 179280 - denyhosts fails to build under mock for fc5/devel due to unpackaged files
denyhosts fails to build under mock for fc5/devel due to unpackaged files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: denyhosts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 15:26 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 17:14:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-01-29 15:26:22 EST
Description of problem:
denyhosts won't build under mock for fc5/devel due to unpackaged files. 

End of the build.log from mock: 

Processing files: denyhosts-1.1.4-2.fc5
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.70008
+ umask 022
+ cd /builddir/build/BUILD
+ cd DenyHosts-1.1.4
+ DOCDIR=/var/tmp/denyhosts-1.1.4-2.fc5-root-mockbuild/usr/share/doc/denyhosts-1.1.4
+ export DOCDIR
+ rm -rf /var/tmp/denyhosts-1.1.4-2.fc5-root-mockbuild/usr/share/doc/denyhosts-1.1.4
+ /bin/mkdir -p
/var/tmp/denyhosts-1.1.4-2.fc5-root-mockbuild/usr/share/doc/denyhosts-1.1.4
+ cp -pr CHANGELOG.txt denyhosts.cfg-dist LICENSE.txt
/var/tmp/denyhosts-1.1.4-2.fc5-root-mockbuild/usr/share/doc/denyhosts-1.1.4
+ cp -pr README.fedora README.txt setup.py
/var/tmp/denyhosts-1.1.4-2.fc5-root-mockbuild/usr/share/doc/denyhosts-1.1.4
+ exit 0
Provides: config(denyhosts) = 1.1.4-2.fc5
Requires(interp): /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(post): /bin/sh
Requires(preun): /bin/sh
Requires: /bin/bash /usr/bin/env /usr/bin/python config(denyhosts) = 1.1.4-2.fc5
openssh-server python(abi) = 2.4
Checking for unpackaged file(s): /usr/lib/rpm/check-files
/var/tmp/denyhosts-1.1.4-2.fc5-root-mockbuild
error: Installed (but unpackaged) file(s) found:
   /usr/bin/denyhosts.pyc
   /usr/bin/denyhosts.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/__init__.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/allowedhosts.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/constants.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/counter.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/daemon.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/deny_hosts.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/denyfileutil.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/filetracker.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/lockfile.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/loginattempt.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/old-daemon.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/plugin.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/prefs.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/python_version.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/regex.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/report.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/util.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/version.pyo


RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/bin/denyhosts.pyc
   /usr/bin/denyhosts.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/__init__.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/allowedhosts.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/constants.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/counter.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/daemon.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/deny_hosts.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/denyfileutil.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/filetracker.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/lockfile.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/loginattempt.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/old-daemon.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/plugin.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/prefs.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/python_version.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/regex.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/report.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/util.pyo
   /usr/lib/python2.4/site-packages/DenyHosts/version.pyo

Full build.log on request.
Comment 1 Jason Tibbitts 2006-01-30 16:46:12 EST
So, what on earth are .pyc and .pyo files?  (Sorry, I don't speak much Python
and find its install process hilariously bad.)  Obviously they're not required,
and my systems don't have this problem even though I always build with
%_unpackaged_files_terminate_build and %_missing_doc_files_terminate_build.

Oh, well, I'll rev the spec to delete these files.
Comment 2 Jason Tibbitts 2006-01-30 17:14:33 EST
Updates pushed and built successfully on the devel branch.

I still have no idea what caused this.  Perhaps the python update on the 24th? 
Older releases don't seem to have created those files.
Comment 3 Kevin Fenzi 2006-01-30 17:16:09 EST
See: 

http://fedoraproject.org/wiki/Packaging/Python

You didn't see these likely because you didn't build as root, but mock does. 

They suggest in the above url that you package the .pyc files, and set things to
not build the .pyo files and %ghost them in the files section so they are
removed on uninstall. 
Comment 4 Jason Tibbitts 2006-01-30 18:24:39 EST
Interesting.  I've reworked a bit of the spec to better meet those guidelines
and have pushed a build.  Feel free to check over the current specfile and see
if I've done anything wrong.  This package was imported before we had the
current rigorous review guidelines in place so it saw far less scrutiny than it
would if it were submitted now.
Comment 5 Kevin Fenzi 2006-01-30 18:36:44 EST
Yeah, those changes look all good to me. I'm no python packaging guru, but I
think those changes do the right thing. ;) 

Thanks for fixing it up.

Note You need to log in before you can comment on or make changes to this bug.