Bug 179288 - feh doesn't build under current fc5/devel mock due to missing BuildRequires
feh doesn't build under current fc5/devel mock due to missing BuildRequires
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: feh (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aaron Kurtz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 15:59 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.4.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 05:22:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-01-29 15:59:58 EST
Description of problem:
feh doesn't build under current fc5/devel mock due to missing BuildRequires

End of build.log from mock:

gcc -DHAVE_CONFIG_H -I. -I. -I. -I/usr/X11R6/include                     
-I/usr/include -I/usr/include                     -I. -I../src                 
   -I/usr/local/include/libpng      -DPREFIX=\""/usr"\"                     
-I/usr/include/giblib    -I/usr/X11R6/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables
-I/usr/X11R6/include -c options.c
In file included from main.c:32:
support.h:30:85: error: X11/Intrinsic.h: No such file or directory
make[3]: *** [main.o] Error 1
make[3]: *** Waiting for unfinished jobs....
options.c: In function 'feh_parse_option_array':
options.c:481: warning: pointer targets in passing argument 4 of
'XParseGeometry' differ in signedness
options.c:481: warning: pointer targets in passing argument 5 of
'XParseGeometry' differ in signedness
options.c:416: warning: unused variable 'geomret'
options.c:415: warning: unused variable 'i'
make[3]: Leaving directory `/builddir/build/BUILD/feh-1.3.4/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/feh-1.3.4/src'
make[1]: *** [all-recursive-am] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/feh-1.3.4/src'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.26065 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.26065 (%build)

Looks like missing a BuildRequires for libXt-devel in modular xorg.
Comment 1 Aaron Kurtz 2006-01-31 05:22:08 EST
Added the BuildRequires, updated and built. The package is just waiting to be
signed.

Note You need to log in before you can comment on or make changes to this bug.