Bug 179308 - gai doesn't build under current devel/fc5 mock due to modular xorg changes
gai doesn't build under current devel/fc5 mock due to modular xorg changes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gai (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-29 23:51 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 20:42:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-01-29 23:51:22 EST
Description of problem:
gai doesn't build under current devel/fc5 mock due to modular xorg changes

End of mock build.log: 
checking /usr/X11R6/include/X11/X.h usability... no
checking /usr/X11R6/include/X11/X.h presence... no
checking for /usr/X11R6/include/X11/X.h... no
configure: error: No header files for X windows is found. Is xlib devel installed?
error: Bad exit status from /var/tmp/rpm-tmp.65692 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.65692 (%build)

Looks like it's hard coded to look for the X.h header in the old location. 
New modular xorg has that header in /usr/include/X11/X.h and belonging to 
the xorg-x11-proto-devel package. Perhaps a patch to the configure script and a
BuildRequires for xorg-x11-proto-devel would fix things up. 

Full build.log on request.
Comment 1 Michel Alexandre Salim 2006-01-31 20:42:11 EST
Fix available, waiting for gtkglext update so I can request a simultaneous
rebuild of gai and gai-pal (while gai-pal/gtkglext 1.1.0 works on gai/gtkglext
1.0.6, it's probably better to build both against the same version of gtkglext)

Note You need to log in before you can comment on or make changes to this bug.