Bug 179318 - {cman,dlm,GFS,gnbd}-kernel* not compiled with the last kernel
{cman,dlm,GFS,gnbd}-kernel* not compiled with the last kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: GFS-kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
:
: 179316 179317 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 04:44 EST by Zouhir Hafidi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 22:18:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zouhir Hafidi 2006-01-30 04:44:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The most recent {cman,dlm,GFS,gnbd}-kernel* and {cman,dlm,GFS,gnbd}-kernel-xen* rpms are not compiled against the latest kernels (kernel-2.6.14-1.1656_FC4 and kernel-xen0-2.6.13-1.1532_FC4 respectively).

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1656_FC4 and kernel-xen0-2.6.13-1.1532_FC4

How reproducible:
Always

Steps to Reproduce:
1. rpm -qp --requires cman-kernel-2.6.11.5-20050601.152643.FC4.18.i686.rpm
2. repeat for the other rpms
3.
  

Actual Results:  /bin/sh
/lib/modules/2.6.14-1.1653_FC4
kernel = 2.6.14-1.1653_FC4
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1

and the latest kernel is 2.6.14-1.1656_FC4

Expected Results:  rpms compiled against the latest kernels

Additional info:
Comment 1 Chris Feist 2006-01-30 11:21:26 EST
*** Bug 179317 has been marked as a duplicate of this bug. ***
Comment 2 Chris Feist 2006-01-30 11:21:46 EST
*** Bug 179316 has been marked as a duplicate of this bug. ***
Comment 3 Chris Feist 2006-01-30 11:36:48 EST
These packages have been rebuilt and will be in the fedora testing repository
for a few days before pushing into fedora-updates.
Comment 4 Zouhir Hafidi 2006-01-30 14:36:20 EST
(In reply to comment #3)
> These packages have been rebuilt and will be in the fedora testing repository
> for a few days before pushing into fedora-updates.

Thanks for the updates. I just see them in the testing repository but I haven't
found {cman,dlm,GFS,gnbd}-kernel-xen* ones. Can you build them please.

Note: make sure that all these packages are rebuilt every time a new kernel rpm
is  released. 
Comment 5 Chris Feist 2006-01-30 14:58:15 EST
There is no xen kernel for kernel-2.6.14-1.1656_FC4 and we are unable to release
GFS packages which are built against 2 different kernels.
Comment 6 Zouhir Hafidi 2006-01-30 16:18:22 EST
(In reply to comment #5)
> There is no xen kernel for kernel-2.6.14-1.1656_FC4 and we are unable to release
> GFS packages which are built against 2 different kernels.

I talk about kernel-xen not kernel

actually in the updates repo we can find these rpms:
cman-kernel-xen0-2.6.11.5-20050601.152643.FC4.9.i686.rpm
cman-kernel-xenU-2.6.11.5-20050601.152643.FC4.9.i686.rpm
dlm-kernel-xen0-2.6.11.5-20050601.152643.FC4.10.i686.rpm
dlm-kernel-xenU-2.6.11.5-20050601.152643.FC4.10.i686.rpm
GFS-kernel-xen0-2.6.11.8-20050601.152643.FC4.9.i686.rpm
GFS-kernel-xenU-2.6.11.8-20050601.152643.FC4.9.i686.rpm
gnbd-kernel-xen0-2.6.11.2-20050420.133124.FC4.43.i686.rpm
gnbd-kernel-xenU-2.6.11.2-20050420.133124.FC4.43.i686.rpm
kernel-xen0-2.6.13-1.1532_FC4.i686.rpm
kernel-xen0-devel-2.6.13-1.1532_FC4.i686.rpm
kernel-xenU-2.6.13-1.1532_FC4.i686.rpm
kernel-xenU-devel-2.6.13-1.1532_FC4.i686.rpm

# rpm -qp --requires cman-kernel-xen0-2.6.11.5-20050601.152643.FC4.9.i686.rpm
/bin/sh
/lib/modules/2.6.12-1.1398_FC4xen0
kernel-xen0 = 2.6.12-1.1398_FC4
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1

we can see that cman-kernel-xen0 depends on kernel-xen0 version
2.6.12-1.1398_FC4 and the latest kernel-xen0 available is version
2.6.13-1.1532_FC4. So we need that {cman,dlm,GFS,gnbd}-kernel-xen0* to be
rebuilt against kernel-xen0-2.6.13-1.1532_FC4 and
{cman,dlm,GFS,gnbd}-kernel-xenU* against kernel-xenU-2.6.13-1.1532_FC4
Comment 7 Chris Feist 2006-01-30 17:09:14 EST
cman-kernel-xen0 is built as part of cman-kernel, and in our build we can
currently only specify one kernel version to build against for all variants of
cman-kernel (xen0, xenU, smp, etc.).

Since there is no kernel-xen with the latest kernel we cannot build
cman-kernel-xen0 packages.
Comment 8 Zouhir Hafidi 2006-02-17 18:41:13 EST
OK, now the last kernel is 2.6.15-1.1831_FC4 and {cman,dlm,GFS,gnbd}-kernel* for
this kernel are not available. Please build them and make them available. 
Comment 9 Chris Feist 2006-02-20 13:57:31 EST
These packages should be (or soon be) in the FC4 updates-testing branch and will
be moved the the FC4 updates if no problems are reported.
Comment 10 Bill Nottingham 2006-09-21 22:18:50 EDT
Closing bugs in MODIFIED state from prior Fedora releases. If this bug persists
in a current Fedora release (such as Fedora Core 5 or later), please reopen and
set the version appropriately.

Note You need to log in before you can comment on or make changes to this bug.