Bug 179323 - genhomedircon will not create a new context if user's $HOME is under /opt
genhomedircon will not create a new context if user's $HOME is under /opt
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 05:35 EST by Dominik 'Rathann' Mierzejewski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-10 13:23:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2006-01-30 05:35:30 EST
Description of problem:
  Updating  : selinux-policy-targeted      ##################### [ 38/114]
tripos homedir /opt/tripos or its parent directory conflicts with a
defined context in /etc/selinux/targeted/contexts/files/file_contexts,
/usr/sbin/genhomedircon will not create a new context.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.2.8-1

How reproducible:
Always

Steps to Reproduce:
1. create a user account with $HOME under /opt
2. install/update selinux-policy-targeted
Comment 1 Daniel Walsh 2006-01-30 12:54:05 EST
This is expected behaviour.  genhomedircon is trying to setup file context for
the parent directories of the users homedirs.  If it finds a conflict it will
report the warning, and not override the context.  Have you tried to create
/opt/home/USER?  I believe that would work correctly.

Dan
Comment 2 Dominik 'Rathann' Mierzejewski 2006-02-10 10:37:12 EST
Creating the directory doesn't help. Anyway, it's not a problem for me because
we don't use SELinux, but it might bite somebody else. If it's not a bug, then
please close it. ;)

Note You need to log in before you can comment on or make changes to this bug.