Bug 179325 - localhost are allways prefered regardless of weight
localhost are allways prefered regardless of weight
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 07:00 EST by Klaus Ethgen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 12:03:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 139417 None None None Never

  None (edit)
Description Klaus Ethgen 2006-01-30 07:00:54 EST
Description of problem:

When using a autofs map like
test fileserver1(1):/export/dir fileserver2(2):/export/dir
localhost(9):/afs/org.ch/dir

the localhost mountpoint for afs should only be used if everything else fail.
But if there is localhost then all weighting is just ignored. That's not what is
expected.


Version-Release number of selected component (if applicable):

4.1.3-155

How reproducible:


Steps to Reproduce:
1. Add a indirect map (/test /etc/auto.test rw) to the /etc/auto.master
2. Add a similar line to the above to /etc/auto.test

Actual results:

There will always the bind mount be used

Expected results:

The first available mount point should be used
Comment 1 Jeffrey Moyer 2006-01-30 10:17:09 EST
http://docs.sun.com/app/docs/doc/816-0211/6m6nc66nc?a=view

"Server proximity takes priority in the selection process. [...] The weighting
has effect only when selecting between servers with the same network proximity."
Comment 2 Klaus Ethgen 2006-01-30 11:30:48 EST
(In reply to comment #1)
> http://docs.sun.com/app/docs/doc/816-0211/6m6nc66nc?a=view
> 
> "Server proximity takes priority in the selection process. [...] The weighting
> has effect only when selecting between servers with the same network proximity."

That's not a solution for the problem. The problem is that afs is NOT nearer
than the servers. (And there are several other reasons to do it not the sun
way: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=139417)

Also it is not clear why redhat is destroying the function of the upstream
only to fit exactly the same braindammed way, sun did. (Sorry about the hard
words) The weighting is needed to override such wrong assignment. To make them
useless breaks the use of the package.

The point is that on linux it is expected that the weighting overrides all other
assignments. All known linux distributions including upstream do it the right
way. To destroy this feature in redhat create a high incompatibility to other
linux distributions.

Sorry, but if redhat do add such incompatibility there should be a way to
switch it off.
Comment 3 Jeffrey Moyer 2006-01-30 12:03:56 EST
The replicated server functionality that was committed in the autofs 4.1.x
stream was broken from the start, so citing the way it works upstream is not a
valid argument.  I will also note that the upstream implementation may be
"fixed" in this regard moving forward.

There are many existing installations which include Solaris, AIX, HPUX, Linux,
and other operating systems, all using the same automounter maps.  If one
implementation functions differently from the others, it constitutes a
managability problem.

I fully understand the merits of of the argument posed in bz #139417, but I am
averse to implementing something that makes Linux incompatible with other
automounter implementations.

I am not clear on why you are mixing NFS and AFS, but I will assume that you
have good reason to do so.  If you are willing to post your maps and more
information about your configuration, I'm happy to work with you to find an
alternative solution to your problem.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.