Bug 179369 - pata drives no longer found on sata_promise controller
pata drives no longer found on sata_promise controller
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 12:29 EST by James C. Bevier
Modified: 2015-01-04 17:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 23:42:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to provide pata support on sata_promise controller (4.57 KB, patch)
2006-02-08 15:37 EST, James C. Bevier
no flags Details | Diff
Spec file to include patch previously posted (106.39 KB, text/plain)
2006-02-08 15:39 EST, James C. Bevier
no flags Details

  None (edit)
Description James C. Bevier 2006-01-30 12:29:48 EST
Description of problem: Pata drives are no longer found by sata_promise driver 
when booting the system.  Here is the lspci information:

[root@nugget ~]# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host Bridge 
(rev 01)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 
South]
00:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller 
(rev 80)

00:08.0 RAID bus controller: Promise Technology, Inc. PDC20378 (FastTrak 
378/SATA 378) (rev 02)

00:0a.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit 
Ethernet Controller (rev 13)
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID 
Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. 
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge 
[KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 
AC97 Audio Controller (rev 60)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM 
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] 
(rev a1)

[root@nugget ~]# lspci -v -n -s 00:08.0
00:08.0 0104: 105a:3373 (rev 02)
        Subsystem: 1043:80f5
        Flags: bus master, 66MHz, medium devsel, latency 96, IRQ 177
        I/O ports at ec00 [size=64]
        I/O ports at dc00 [size=16]
        I/O ports at cc00 [size=128]
        Memory at f7800000 (32-bit, non-prefetchable) [size=4K]
        Memory at f7700000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: [60] Power Management version 2

Version-Release number of selected component (if applicable):
[root@nugget ~]# uname -a
Linux nugget 2.6.15-1.1881_FC5 #1 SMP Fri Jan 27 15:52:27 EST 2006 x86_64 
x86_64 x86_64 GNU/Linux

-------part of dmesg log on boot---------

sata_promise 0000:00:08.0: version 1.03
GSI 17 sharing vector 0xB1 and IRQ 17
ACPI: PCI Interrupt 0000:00:08.0[A] -> GSI 18 (level, low) -> IRQ 177
ata3: SATA max UDMA/133 cmd 0xFFFFC20000004200 ctl 0xFFFFC20000004238 bmdma 
0x0 irq 177
ata4: SATA max UDMA/133 cmd 0xFFFFC20000004280 ctl 0xFFFFC200000042B8 bmdma 
0x0 irq 177
input: ImPS/2 Generic Wheel Mouse as /class/input/input1
ata3: SATA link down (SStatus 0)
scsi2 : sata_promise
ata4: SATA link down (SStatus 0)
scsi3 : sata_promise

How reproducible:  Always.


Steps to Reproduce:
1.Boot kernel 1881 for FC5T2 with K8VSE Deluxe motherboard and pata drives on 
sata_promise controller.
2.
3.
  
Actual results:  pata drives not found.


Expected results: pata drives should be /dev/sda & /dev/sdb.


Additional info:  I provided the patch for kernel 771 over a year ago to Dave 
Jones and it has been in the kernel ever since.  I would like to se  my drives 
again.  I do not have time to debug this problem right now.
Comment 1 Kevin Hobbs 2006-02-01 14:11:28 EST
I think I have the exact same hardware.  I've been seeing this off and on for a
while.  I'm only using FC4 not the devel branch.  I thought the funny bit was
that the installer could see discs on the parallel port of that controller but
the installed kernel could not.  I've sence updated to kernel-2.6.14-1.1656_FC4
which sees the disc.
Comment 2 James C. Bevier 2006-02-08 15:37:56 EST
Created attachment 124402 [details]
patch to provide pata support on sata_promise controller

Modified spec fill will be attached too.
Comment 3 James C. Bevier 2006-02-08 15:39:45 EST
Created attachment 124404 [details]
Spec file to include patch previously posted

Spec file for sata_promise patch.
Comment 4 James C. Bevier 2006-02-08 15:47:49 EST
Here is a patch I modified from the one I used to use on kernel 2.6.10 before 
the patch was integrated into the kernel.  I have built a working kernel that 
supports pata drives on the Promise Controller model PDC20378 that is on the 
K8V-SE Deluxe motherboard.  I can now read/write the two PATA drives connected 
to the controller.  This patch needs to be put in the next kernel so other can 
test it.  I built it against the kernel 2.6.15-1.1915 that was in RawHide 
today.
Comment 5 Rahul Sundaram 2006-02-20 05:56:43 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 6 James C. Bevier 2006-03-01 11:56:43 EST
The included patch has still not been included into the FC5T3 kernel builds.  
The patch is from the 2.6.16 libata patch file and developed by Erik Benena.  
This code was in FC4, but was somehow removed from the 2.6 kernel.  I really 
need this code back into the mainstream kernel.  Time is getting short for the 
FC5 release.
Comment 7 Dave Jones 2006-03-01 23:42:52 EST
fixed in cvs.
should be in tomorrows build if it gets through teh buildsys fast enough
(otherwise, it'll be at http://people.redhat.com/davej/kernels/Fedora/devel
until the day after)

It'll be in kernel-2.6.15-1.2005_FC5 and higher.

Note You need to log in before you can comment on or make changes to this bug.