Bug 179373 - rhythmbox crashes on startup if you run it with MALLOC_PERTURB_="149"
rhythmbox crashes on startup if you run it with MALLOC_PERTURB_="149"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 12:59 EST by Dave Jones
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-01 16:47:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-01-30 12:59:35 EST
rhythmbox crashes on startup if you run it with MALLOC_PERTURB_="149"

(gdb) bt
#0  0x0000003aaa2728c0 in strcmp () from /lib64/libc.so.6
#1  0x00002b871c64929d in g_str_equal () from /usr/lib64/libglib-2.0.so.0
#2  0x00002b871c6268f2 in g_hash_table_lookup () from /usr/lib64/libglib-2.0.so.0
#3  0x000000000045b862 in rhythmdb_idle_poll_events (db=0x926000) at rhythmdb.c:1409
#4  0x00002b871c630e91 in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#5  0x00002b871c633cad in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#6  0x00002b871c633ffe in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#7  0x00002b871b9c7904 in bonobo_main () from /usr/lib64/libbonobo-2.so.0
#8  0x00000000004276a5 in main (argc=1, argv=0x7fffffb8de68) at main.c:398
Comment 1 Christopher Aillon 2006-02-01 02:18:49 EST
I've been tracking rhythmbox lately, will have a look in the morning.
Comment 2 Christopher Aillon 2006-02-01 15:36:17 EST
Which version are you using?  I just did:

export MALLOC_PERTURB_="149"
rhythmbox

using rhythmbox-0.9.2.cvs20060123-1 both my i386 laptop and my x86_64
workstation (64bit) and neither of them crashed...
Comment 3 Christopher Aillon 2006-02-01 16:13:07 EST
Also, I just built a newer CVS snapshot (0.9.2.cvs20060201) which had a 64bit
crash fix in the changelog since the last snapshot i pulled.  See if that fixes it.
Comment 4 Dave Jones 2006-02-01 16:43:36 EST
I was also running rhythmbox-0.9.2.cvs20060123-1
It crashed whilst it was scanning new oggs that I had added, so it may have only
trigger if you have awesome tunes.

I'll try out the new build when I get home.
Comment 5 Dave Jones 2006-02-01 16:47:07 EST
actually, it was my work machine that died. Just tested latest build, and it
seems to work.

Whee, I have noises again.

Note You need to log in before you can comment on or make changes to this bug.