Bug 179386 - iscsi-ls should use modinfo to display driver version
Summary: iscsi-ls should use modinfo to display driver version
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Mike Christie
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 181409
TreeView+ depends on / blocked
 
Reported: 2006-01-30 20:24 UTC by Mike Christie
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHBA-2006-0495
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 21:55:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0495 normal SHIPPED_LIVE iscsi-initiator-utils bug fix update 2006-08-10 04:00:00 UTC

Description Mike Christie 2006-01-30 20:24:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
iscsi-ls currently has its driver version hardcoded. This makes maintenance a problem because very time we update the kernel driver we also have to update iscsi-ls. Instead, iscsi-ls should use modinfo to get the module version.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run iscsi-ls
2.
3.
  

Additional info:

Comment 3 Mike Christie 2006-05-02 23:02:48 UTC
I am actually just going to fix this in the header file for now. I have it some
what automated so do I do not modinfo.

For U4 the version output for all the programs should be fixed.

Comment 6 Red Hat Bugzilla 2006-08-10 21:55:35 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0495.html



Note You need to log in before you can comment on or make changes to this bug.