Bug 179393 - kernel BUG at include/asm/spinlock.h:163 / nfs server problems
kernel BUG at include/asm/spinlock.h:163 / nfs server problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-30 16:30 EST by Dave Mussulman
Modified: 2015-01-04 17:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 20:11:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Mussulman 2006-01-30 16:30:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
The bug occurs on a FC4 box running 2.6.13-1.  Attempted NFS mounts to the machine return a permission denied on the NFS client, and the following error on the NFS server (in dmesg and /var/log/messages):

Jan 30 13:41:52 kant kernel: ------------[ cut here ]------------
Jan 30 13:41:52 kant kernel: kernel BUG at include/asm/spinlock.h:163!
Jan 30 13:41:52 kant kernel: invalid operand: 0000 [#1]
Jan 30 13:41:52 kant kernel: SMP 
Jan 30 13:41:52 kant kernel: Modules linked in: nfsd exportfs lockd nfs_acl parport_pc lp parport autofs4 rfcomm l2cap bluetooth sunrpc dm_mod video button battery ac ipv6 ohci1394 ieee1394 uhci_
hcd ehci_hcd i2c_i801 i2c_core snd_intel8x0 snd_ac97_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_a
lloc e1000 floppy ext3 jbd
Jan 30 13:41:52 kant kernel: CPU:    0
Jan 30 13:41:52 kant kernel: EIP:    0060:[<c0317e94>]    Not tainted VLI
Jan 30 13:41:52 kant kernel: EFLAGS: 00010282   (2.6.13-1.1526_FC4smp) 
Jan 30 13:41:52 kant kernel: EIP is at _spin_lock+0x36/0x40
Jan 30 13:41:52 kant kernel: eax: 00000011   ebx: f64d158c   ecx: c036fbf4   edx: 00000296
Jan 30 13:41:52 kant kernel: esi: f64d1584   edi: f64d158c   ebp: f68cbbc0   esp: f7831d30
Jan 30 13:41:52 kant kernel: ds: 007b   es: 007b   ss: 0068
Jan 30 13:41:52 kant kernel: Process nfsd (pid: 2846, threadinfo=f7831000 task=f7f4f020)
Jan 30 13:41:52 kant kernel: Stack: c032d1b4 f8c0cda5 f64d1584 f8c0cda5 f7681600 fbd05ceb f7681600 f64d1740 
Jan 30 13:41:52 kant kernel:        f6a6b814 00000002 f7681600 f8b3b078 c02afdd7 00000078 f7831e9c f7681600 
Jan 30 13:41:52 kant kernel:        f64d1740 f88b94d0 00000001 ffffffff 00000000 c23bb73c 00000000 f7a70a3c 
Jan 30 13:41:52 kant kernel: Call Trace:
Jan 30 13:41:52 kant kernel:  [<f8c0cda5>] nfsd_acceptable+0x45/0x102 [nfsd]
Jan 30 13:41:52 kant kernel:  [<f8c0cda5>] nfsd_acceptable+0x45/0x102 [nfsd]
Jan 30 13:41:52 kant kernel:  [<f8b3b078>] find_exported_dentry+0x78/0x623 [exportfs]
Jan 30 13:41:52 kant kernel:  [<c02afdd7>] sock_recvmsg+0x103/0x11e
Jan 30 13:41:52 kant kernel:  [<c011b106>] activate_task+0x8f/0x9e
Jan 30 13:41:52 kant kernel:  [<c011b6d2>] try_to_wake_up+0x6e/0x328
Jan 30 13:41:52 kant kernel:  [<c011d08b>] __wake_up_common+0x39/0x59
Jan 30 13:41:52 kant kernel:  [<f8c12813>] svc_expkey_lookup+0x371/0x3ef [nfsd]
Jan 30 13:41:52 kant kernel:  [<c011d0dd>] __wake_up+0x32/0x43
Jan 30 13:41:52 kant kernel:  [<f8b3b8ca>] export_decode_fh+0x54/0x7a [exportfs]
Jan 30 13:41:52 kant kernel:  [<f8c0cd60>] nfsd_acceptable+0x0/0x102 [nfsd]
Jan 30 13:41:52 kant kernel:  [<f8b3b876>] export_decode_fh+0x0/0x7a [exportfs]
Jan 30 13:41:52 kant kernel:  [<f8c0d11e>] fh_verify+0x2bc/0x5a5 [nfsd]
Jan 30 13:41:52 kant kernel:  [<f8c0cd60>] nfsd_acceptable+0x0/0x102 [nfsd]
Jan 30 13:41:52 kant kernel:  [<f8c0ec64>] nfsd_access+0x1b/0x10f [nfsd]
Jan 30 13:41:52 kant kernel:  [<f8c16786>] nfsacld_proc_access+0x70/0xa9 [nfsd]
Jan 30 13:41:52 kant kernel:  [<f8c168a6>] nfsaclsvc_decode_accessargs+0x0/0x33 [nfsd]
Jan 30 13:41:52 kant kernel:  [<f8c0b5e4>] nfsd_dispatch+0x76/0x1c2 [nfsd]
Jan 30 13:41:52 kant kernel:  [<f8b62047>] svc_authenticate+0x97/0xae [sunrpc]
Jan 30 13:41:52 kant kernel:  [<f8b5f7c3>] svc_process+0x3b4/0x671 [sunrpc]
Jan 30 13:41:52 kant kernel:  [<c011d046>] default_wake_function+0x0/0xc
Jan 30 13:41:52 kant kernel:  [<f8c0b3ab>] nfsd+0x184/0x347 [nfsd]
Jan 30 13:41:52 kant kernel:  [<c0103a42>] syscall_exit_work+0x12/0x18
Jan 30 13:41:52 kant kernel:  [<f8c0b227>] nfsd+0x0/0x347 [nfsd]
Jan 30 13:41:52 kant kernel:  [<c0101ca1>] kernel_thread_helper+0x5/0xb
Jan 30 13:41:52 kant kernel: Code: ad de 75 13 f0 fe 0b 79 09 f3 90 80 3b 00 7e f9 eb f2 83 c4 08 5b c3 8b 44 24 0c 89 44 24 04 c7 04 24 b4 d1 32 c0 e8 b3 97 e0 ff <0f> 0b a3 00 e0 c9 32 c0 eb cf
 81 78 04 ed 1e af de 75 0f f0 81 
Jan 30 13:41:52 kant kernel:  eip: f8c0cda5


Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1456_FC4

How reproducible:
Always

Steps to Reproduce:
1. Error occurs multiple times 60+ at bootup after the NFS service starts and shares don't work right.
2.
3.
  

Expected Results:  Downgrading the running kernel to 2.6.12-1 resolves the issue and NFS with the same configuration operates normally.

Additional info:
Comment 1 Dave Jones 2006-02-02 20:11:56 EST
There have been a lot of NFS changes since 2.6.13, making this trace almost
useless.  Please reopen if you can reproduce it with the latest update.
(currently 2.6.14, but there's a 2.6.15 out in a day or so, you can grab it
early from http://people.redhat.com/davej/kernels/Fedora/FC4/).

Note You need to log in before you can comment on or make changes to this bug.